It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Hmmm. Just loaded up the game with the Revision mod. It's pretty unplayable for me. It's far too dark on my colour calibrated monitor and the brightness setting slider does nothing in game.
Anyone have any suggestions?
I haven't installed it but that's one of the very consistent, first complaints everyone seems to have with the mod (among many others). I checked a few gameplay vids on youtube to have a look, and sure enough, it is way too dark. It ruins the game. What's worse, from the threads and comments I've seen, this has been a problem since the very beginning, and complaints about this were flooding from even the beta stage, before the mod's official release. But the dev(s?) just constantly ignored them.

Anyway. To their detriment. I was considering it but have decided now not to bother with this Revision thing after all, even for free.
But the lighting was improved in the 1.0.1 patch from 21st October 2015, only a week after the release.
The lighting gets a bit better If I swap to software rendering but then the visuals don't look as good.
avatar
SqueakyDave: The lighting gets a bit better If I swap to software rendering but then the visuals don't look as good.
Have you tried switching between windowed and full screen? I think that might make a difference.
I can't find a way to change the rendering method in Revision, be it at the first launch or through the display options menu. The problem does not occur with vanilla Deus Ex. Right now, the only option is Direct3D. Not unlike a Model T Ford, you can have it in any color, provided it's black...

Any idea?
Try installing the OpenGL renderer from http://www.cwdohnal.com/utglr/dxglr21.zip

Or DirectX10 from http://kentie.net/article/d3d10drv/
avatar
Hawkbird: Try installing the OpenGL renderer from http://www.cwdohnal.com/utglr/dxglr21.zip

Or DirectX10 from http://kentie.net/article/d3d10drv/
Thanks for the tip, but neither add-on did the trick. The first simply doesn't show up, the second leads to an error message.
avatar
Hawkbird: Try installing the OpenGL renderer from http://www.cwdohnal.com/utglr/dxglr21.zip

Or DirectX10 from http://kentie.net/article/d3d10drv/
avatar
Dalswyn: Thanks for the tip, but neither add-on did the trick. The first simply doesn't show up, the second leads to an error message.
When choosing the rendering device, have you switched to "show all devices"? I had do do that to pick the openGL driver, now brightness setting works as it should.
avatar
Dalswyn: Thanks for the tip, but neither add-on did the trick. The first simply doesn't show up, the second leads to an error message.
avatar
drhardware: When choosing the rendering device, have you switched to "show all devices"? I had do do that to pick the openGL driver, now brightness setting works as it should.
I did, to no avail. By default, Revision only gives me one option.
Go to your documents folder, deusex.ini and change OneXBlending=True to OneXBlending=False. Also you can mess with the gamma there if its still to dark.
avatar
glitchyjoe64: Go to your documents folder, deusex.ini and change OneXBlending=True to OneXBlending=False. Also you can mess with the gamma there if its still to dark.
As soon as I'm able to make my AV understand that, no, Revision has not turned into a trojan horse overnight, I shall try this! :)
avatar
glitchyjoe64: Go to your documents folder, deusex.ini and change OneXBlending=True to OneXBlending=False. Also you can mess with the gamma there if its still to dark.
avatar
Dalswyn: As soon as I'm able to make my AV understand that, no, Revision has not turned into a trojan horse overnight, I shall try this! :)
Windows defender is good enough for one with common sense. ',:)
avatar
jigglywiggly: I haven't installed it but that's one of the very consistent, first complaints everyone seems to have with the mod (among many others).
It's not an issue with Revision but with the base game, bro. Playing vanilla Deux Ex GOTY with the Direct3D renderer the game is unplayably dark and the brightness slider does nothing. It's the other way around, Revision actually fixes the brightness issue. :P
avatar
glitchyjoe64: Go to your documents folder, deusex.ini and change OneXBlending=True to OneXBlending=False. Also you can mess with the gamma there if its still to dark.
I'm gonna try this.
In my case, the brightness starts out alright after first loading a save, but the game slowly turns darker within a few minutes. Loading another savegame without first restarting Deus Ex also leads to a darker screen.