It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

The Game seems to play perfectly normal until I hit a cinematic at witch point the audio slowly falls out of sync with the video, getting worse as the cinematic progresses. After the cinematic ends thou all is well again so it seems to be localized to only the cinematics.
Anyone else getting this and/or know of a possible fix?
Post edited June 16, 2015 by Wiseworgen.739
Yup. Try to running it without the Galaxy - in my case launching the game from a shortcut fix it. As a side note - Galaxy was turned off when I played Darksiders, and I'm not sure if it (Galaxy) detects other launches, or it have to be from the app.