It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Okay, so I’m pulling my hair out at this point. I’m experiencing a ridiculous bug - basically, the game just does not create any save files for me.
Ever since I installed the game, every time I try to quit, the game just boots me out into the intro cutscene and starts me completely anew, as if my save didn’t even exist. I do get the saving icon whenever I manually use “save” option in the pause menu or when I get an auto-save, but like I said, every attempt at quitting the game results in complete start from scratch.

I reinstalled a bunch of times, launched in admin mode, etc, but nothing works. I went into the folder where the saves are supposed to be stored, but as expected, there are no save files there.
Has someone ever experienced this?
Would appreciate any support as the game by itself is running fine for me, it’s just I physically cannot complete it because my progress just gets yeeted out of existence each time I try to quit.
Have you tried alt-tabbing out to check the save file location after saving to see if anything is saved there?

Edit: For the actual support section (and not the general Darksiders discussion area) go to
Post edited September 27, 2020 by WingedKagouti
Just a late update post - after trying all fixes known to man, unfortunately had to file a refund for the game. There seemed to be something weird going on with the save folder being duplicated in different locations, but I was unable to find a solution to this.
Recently bought the game on steam and it worked perfectly fine (at least saving is working fine), so if someone stumbles upon my post, keep in mind that steam version doesn’t have this issue (in my experience at least).

Edit: grammar
Post edited October 21, 2020 by Neophyx_21