It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

NOTE: Solution posted by Lightfax in another topic

PROBLEM: Introductory audio is unusual, some music is out of sync, and combat sounds like random notes rather than clashing swords.

1) Rename PSOUND.DLB and PSOUND.DLC to PSOUND.DLB.old and PSOUND.DLC.old ...
(In case you don't see a PSOUND.DB, you have Windows hiding known exceptions. To see the extension and rename it, press "Alt-T" and select "Folder options." Click the "View" tab, uncheck "Hide extensions for known file types" and click "Ok" -- now you should be able to see PSOUND.DB and be able to rename it.)

EXPLANATION: The downloadable version has a fix applied to it for the old fashioned Roland MIDI cards combined with a normal DMA card (Sound Blaster or Pro Audio Spectrum). See "dlroldma.txt" in the "DARKLAND" folder.
The original ASOUND.DLB/DLC and PSOUND.DLB/DLC files were renamed ASOUND.DB/DC and PSOUND.DB/DC; and they were replaced with renamed RSOUND.DLB/DLC files. Restoring the PSOUND files is all that is needed to get the original audio back, as the game configuration is set to the newer audio.
The reason the RSOUND audio doesn't work right is due to 2 reasons. 1) how it is emulated in DOSBox. 2) MIDI samples have changed in 20 years, so the RSOUND music is miscoded (I believe).

A tip for Windows XP users: To see the extensions go to My Computer -> Tools -> Folder Options -> View and uncheck "Hide extensions for known file types".
Post edited November 18, 2011 by Ethaar