It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi guys!

TL:DR This makes things even better : http://www.darkreign.ws/patch/

Our version of this game is 1.4, which is is the latest official release. However, the wonderful Dark Reign community created Patch 1.7 (http://www.darkreign.ws/patch/) that fixes many issues that were still present after the last official update, most notably the lack of TCP/IP multilayer support. We can't use the 1.7 patch for obvious reasons, but it is highly recommended. :)
In addition, the http://www.darkreign.ws/ community is still active and it is a nice place to find other people interested in this title.

IMPORTANT NOTICE: The 1.7 version is disabling the in game music.
Post edited January 28, 2011 by Paczyk
Those exes are just packed up and thats the reason why it think thats virus.

Beside - be warned - community patches are including cracks! (my eng sux)
Post edited March 01, 2011 by Day7
avatar
Day7: Beside - be warned - community patches include cracks!
WHAT?!? then my infantry will shoot like shit!
Better get them on rehab!
Warning people,
This "patch" is cracked shit and contains various trojans, no false alarms. Let me give you a good advice, do not download this.
I installed the game and played the first mission for a bit and everything worked just fine but suddenly the colours got inverted (or something that kinda looked like that). I thought well yeah that can happen with these old games let's look at some patches.

I found darkreign.ws as the first google hit and downloaded what I thought was a patch (but turned out to be the actual game Oo). I extracted the zip I downloaded and my AV went nuts with generic malware alerts. I ignored those. after extraction I started the game but the colours were screwed up right away. I later tried messing with compatibility mode but then my AV said it detected a specific trojan. at that point I booted that 1.7 version off my pc.

so I went back to the gog version and tried booting it up. now THAT one keeps asking for a cd key! even after de-installing and reinstaling from the gog installer. I can get to the main menu by answering no (I don't have a disk) but the colours are screwed up there too, regardless of compatibility setting. I can't start a game either as it'll ask for a cd.

anyone know of something to try before I ask for a refund?
i cannot launch using the default shortcut pointing to launcher.exe

when i point it to dr2.exe, it starts, but says i have to put the original game CD in the drive first.

i thought GOG removed DRM's from the games.
avatar
Red_Devil_US: i cannot launch using the default shortcut pointing to launcher.exe

when i point it to dr2.exe, it starts, but says i have to put the original game CD in the drive first.

i thought GOG removed DRM's from the games.
To play GOG's Dark Reign 2, you need to launch it through laucher.exe.
Also, please open a new thread for your DR2 issue, as this thread is about the community patch for DR1.
So I downloaded and installed this 1.7 thing, got the same Trojan issue. MSE quarantined it. The game seems to work fine just... why am I listening to the Rebel Moon Rising soundtrack? Don't get me wrong, I loved Rebel Moon Rising, but that music was for an FPS. I had no problems with the original Dark Reign OST...
I'm trying to get Dark Reign working and neither the reg edit hacks nor the 1.7 patch are working for me.

Has any one got any further help if neither 1.7 or the reg edits are working?
Post edited October 31, 2013 by BEN123
Or has anyone had any luck operating the game on windows virtual machine? I'm kinda noobing out on how to get that working exactly...
Color fix that is suggested on the 1.7 patch page for Win 7 does not work. I've tried everything, including setting properties of that bat file to use different compatibility modes but it still shows all colors messed up.
The game is currently unplayable because of this.

Perhaps this is an ATI driver issue, since also other players reporting that this fix does not work also have ATI graphic cards.
Post edited December 29, 2013 by liljedah
avatar
Paczyk: Hi guys!

TL:DR This makes things even better : http://www.darkreign.ws/patch/

Our version of this game is 1.4, which is is the latest official release. However, the wonderful Dark Reign community created Patch 1.7 (http://www.darkreign.ws/patch/) that fixes many issues that were still present after the last official update, most notably the lack of TCP/IP multilayer support. We can't use the 1.7 patch for obvious reasons, but it is highly recommended. :)
In addition, the http://www.darkreign.ws/ community is still active and it is a nice place to find other people interested in this title.

IMPORTANT NOTICE: The 1.7 version is disabling the in game music.
Any ideas on how to apply the 1.7 patch to an existing 1.4 installation of the GOG version?

I could not get my GOG version to run on Win 7, at all. So I downloaded the 1.7 patch but that just created its own 294 MB folder with its own subfolders and executable files and no info on how to merge it with an existing installation.
The 1.7 patch seems to be a working version of the entire game rather than just a patch, and when I launch it and try to start a solo campaign, I get an in-game message telling me to 'insert an original CD ROM'.

So the problem is, the 1.7 patch run by itself doesn't seem to run without discs unless it can somehow be merged with the DRM free GOG installation, but how?
What just happened? it seams that www.darkreign.ws is offline :O. Financial problems? i would donate.
avatar
awalterj: I could not get my GOG version to run on Win 7, at all. So I downloaded the 1.7 patch but that just created its own 294 MB folder with its own subfolders and executable files and no info on how to merge it with an existing installation.
The 1.7 patch seems to be a working version of the entire game rather than just a patch, and when I launch it and try to start a solo campaign, I get an in-game message telling me to 'insert an original CD ROM'.

So the problem is, the 1.7 patch run by itself doesn't seem to run without discs unless it can somehow be merged with the DRM free GOG installation, but how?
I've got the same problem when I try the so called "Patch 1.7", and I'm starting to think that GOG's version isn't DRM free either, as I'm having issues with the "Insert CD" message from the copy bought from them as well.

Another issue (Not sure if this one's been solved or not, I can't find a solution anywhere), is the graphics going all screwy when you actually load into a mission. The fixes all work for the menu but not for the gameplay itself.

I'm running windows 7 64bit and I've tried literally everything under the sun to get it working. :/
avatar
Lawman7072: I've got the same problem when I try the so called "Patch 1.7", and I'm starting to think that GOG's version isn't DRM free either, as I'm having issues with the "Insert CD" message from the copy bought from them as well.

Another issue (Not sure if this one's been solved or not, I can't find a solution anywhere), is the graphics going all screwy when you actually load into a mission. The fixes all work for the menu but not for the gameplay itself.

I'm running windows 7 64bit and I've tried literally everything under the sun to get it working. :/
That's strange, I assume you already tried a taskkill batch file to close Win Explorer which usually helps to fix the 'psychedelic mushrooms' color problems (along with other measures such as checking the disable desktop composition option etc).
I had the opposite problem with the menu being screwed up and the graphics in-game looking normal. Currently I can't run the game at all. GOG support has been responsive and helpful but I've temporarily given up on trying to get this game to run.
Some user reviews have warned that Dark Reign can be troublesome or downright impossible on Win7 but I chose to ignore the warnings and bought it on sale here. No big loss financially...but I wish I could play it. Sorry if I'm unable to help you out here, still haven't been able to figure things out, either. First time I can't get a GOG game to run properly :(
avatar
EPurpl3: What just happened? it seams that www.darkreign.ws is offline :O. Financial problems? i would donate.
The site is up and running right now, maybe they were doing server maintenance last time you checked.
Post edited April 18, 2014 by awalterj
avatar
awalterj: That's strange, I assume you already tried a taskkill batch file to close Win Explorer which usually helps to fix the 'psychedelic mushrooms' color problems (along with other measures such as checking the disable desktop composition option etc).
I had the opposite problem with the menu being screwed up and the graphics in-game looking normal. Currently I can't run the game at all. GOG support has been responsive and helpful but I've temporarily given up on trying to get this game to run.
Killing explorer fixes the menu in game, but leaves the in-game graphics still looking pretty high.

As far as I can tell, GOG version runs fine until you start playing with the run settings or the "Patch 1.7". I copied the "Patch 1.7" across to my laptop, and it ran just the same as on the desktop, same problems etc, without anything from GOG.

So I'm wondering how you used the files to patch up GOG's copy, and if that was what perhaps fixes the in-game graphics? I've tried copying/replacing the files directly, but that doesn't appear to work either.
Attachments: