It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
The first area, Grand Teakettle's Hut does nothing to introduce you to the tutorial and I believe it is broken.

The keyboard key overlays at the top / bottom of the screen are disjointed, overlaid atop each other and the command they are bound to, or just the "A" key which doesn't correspond ot anything.
Post edited September 29, 2017 by harkejuice
I'm having this issue as well, the entire game seems unresponsive to controls. I managed to enter the tutorial after multiple restarts of the game, but could not use the exit door.
The keyboard is able to navigate menus fine and my controller can be mapped, but otherwise it simply ignores a lot of inputs.
I tried to start a new topic about an issue I'm having, but to no avail, so I'll post here instead.

I detest gamepad vibration, and there doesn't appear to be any way to disable it in the in-game settings, and there also doesn't appear to be a way to disable vibration for the gamepad itself. Does anyone know a workaround that doesn't involve opening it up and removing the part that causes the rumbling? I'm using a wireless 360 gamepad in Windows 10.
avatar
finkleroy: I tried to start a new topic about an issue I'm having, but to no avail, so I'll post here instead.

I detest gamepad vibration, and there doesn't appear to be any way to disable it in the in-game settings, and there also doesn't appear to be a way to disable vibration for the gamepad itself. Does anyone know a workaround that doesn't involve opening it up and removing the part that causes the rumbling? I'm using a wireless 360 gamepad in Windows 10.
Open the file Gamepad.dll (*\Cuphead\Cuphead_Data\Plugins) using Notepad++ and delete the value SetGamepadVibration.
Attachments:
avatar
Gibist: Open the file Gamepad.dll (*\Cuphead\Cuphead_Data\Plugins) using Notepad++ and delete the value SetGamepadVibration.
That didn't work for me, so I guess I'll have to wait for a patch. Thanks for trying to help, though. I appreciate it.
Post edited September 30, 2017 by finkleroy
Is it also too much to ask for at least the left mouse button and the right mouse button to be added to the pool of keys actions can be bound to?
Without having to whip up yet another autohotkey script?

I'd really really appreciate that.
I'm completely shut out from entering the tutorial, and had to go to the menu and "exit to map" to continue doing anything.
Also I think I'm supposed to be able to interact with the characters on the map-screen, currently I'm not.

<s>Issue persist regardless of me having the controller plugged in or not.</s>

edit:
Got rid of the issue with a computer reboot with no controller plugged in.
Issue reappears once the controller is plugged back in.

The issue seems to be the controller not having mapped correctly on map and menu input.
Post edited October 02, 2017 by umhyuk
I am having this same issue. Like the user above, I can enter the tutorial and such if no controller is connected, but as soon as a controller is connected, no pop-ups to start the tutorial, exit tutorial, select levels etc. appear and entering the inputs required in the right locations change nothing. Really hope for a fix here.
I'm having this issue as well, using FC30 8bitdo controller.
I'm having the same problems with two different gamepads, but here's my workaround:

Go to the options menu and select controls, where you can remove your controller. Now you can use your keyboard to

- talk to the Elder Kettle, select the tutorial and leave it
- talk to NPCs on the map
- talk to Mr. Dice in the dice buildings

There are no other situations that would require this workaround. To use your gamepad again, simply activate it in the control options with "assign controller". Even with a gamepad assigned you can go to the boss stages on the map by pressing [Enter] on the keyboard.

I'm pretty sure this will work at least for bigbloss, as I use the same 8bitdo controller.
Post edited October 05, 2017 by colorito
I am using the Nintendo Switch pro controller paired to Windows 7.
I can assign controls easily except for the analog sticks that don't respond.

Also, the controller doesn't respond to menus and map for there's no option to assign accept/cancel button, for example.

Every time I die, I have to hit Enter on my keyboard.

Please give us the option to use only the controller for all inputs.
Post edited October 08, 2017 by diegomatias
The only issue I've faced was when after beating the game, my control (360 controller) is not resonding... so I have to kill game and start it again. It's not a big deal.
I'm playing with Dualshock 4 with no problems except the damn vibration, I had to disable it from ds4win.

I tried playing with a Hori VX, an arcade controller for x360/pc and had multiple troubles with it, for starters I had to configurate it manually (the DS4 was detected straight as an xbox controller, no config necessary). Even if the controller is configured and I can play the game I still can't pause or use interface stuff (like advancing dialogue or use the Y menu), I end having to use the keyboard for all that.
Also the label which normally would say "A" to enter places doesn't show while using the Hori controller.

It's pretty much the first game that gave me issues with this joystick, everything else just detects it as an xbox controller.
avatar
efexuy: I'm playing with Dualshock 4 with no problems except the damn vibration, I had to disable it from ds4win.

I tried playing with a Hori VX, an arcade controller for x360/pc and had multiple troubles with it, for starters I had to configurate it manually (the DS4 was detected straight as an xbox controller, no config necessary). Even if the controller is configured and I can play the game I still can't pause or use interface stuff (like advancing dialogue or use the Y menu), I end having to use the keyboard for all that.
Also the label which normally would say "A" to enter places doesn't show while using the Hori controller.

It's pretty much the first game that gave me issues with this joystick, everything else just detects it as an xbox controller.
I can't even get my Hori RAP for xbox one/360/pc to be detected by the game in any way. Kind of frustrating since this is one of the reasons I even got it and have no issues with the other games I've tried using it.
avatar
colorito: I'm having the same problems with two different gamepads, but here's my workaround:

Go to the options menu and select controls, where you can remove your controller. Now you can use your keyboard to

- talk to the Elder Kettle, select the tutorial and leave it
- talk to NPCs on the map
- talk to Mr. Dice in the dice buildings

There are no other situations that would require this workaround. To use your gamepad again, simply activate it in the control options with "assign controller". Even with a gamepad assigned you can go to the boss stages on the map by pressing [Enter] on the keyboard.

I'm pretty sure this will work at least for bigbloss, as I use the same 8bitdo controller.
ITS WORK THX