It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

When trying to run on Ubuntu 19.10, I get a mess of different missing library errors.

./NecroDancer: error while loading shared libraries: cannot open shared object file: No such file or directory

I tried to get around it by looking for on my machine and symlinking it in /usr/lib, and got:

./NecroDancer: error while loading shared libraries: wrong ELF class: ELFCLASS64

Is this game 32-bit? I tried to install 32-bit GL libraries and got another missing library error, for some other library.

I thought I'd played this game on Linux before. Did it break recently? Or has it always been broken on 64-bit machines?
The game is indeed compiled for 32-bit libraries. If you check `ldd Necrodancer` you can see what the game needs. On my Debian system, these are the 32-bit libraries it needs along with the packages that provide them:

libgl1:i386: /usr/lib/i386-linux-gnu/
libopenal1:i386: /usr/lib/i386-linux-gnu/
libogg0:i386: /usr/lib/i386-linux-gnu/
libvorbis0a:i386: /usr/lib/i386-linux-gnu/
libc6:i386: /lib/i386-linux-gnu/
libstdc++6:i386: /usr/lib/i386-linux-gnu/
libc6:i386: /lib/i386-linux-gnu/
libgcc1:i386: /lib/i386-linux-gnu/
libc6:i386: /lib/i386-linux-gnu/
libglx0:i386: /usr/lib/i386-linux-gnu/
libglvnd0:i386: /usr/lib/i386-linux-gnu/
libc6:i386: /lib/i386-linux-gnu/
libsndio7.0:i386: /usr/lib/i386-linux-gnu/
libc6:i386: /lib/i386-linux-gnu/
libatomic1:i386: /usr/lib/i386-linux-gnu/
libx11-6:i386: /usr/lib/i386-linux-gnu/
libxext6:i386: /usr/lib/i386-linux-gnu/
libasound2:i386: /usr/lib/i386-linux-gnu/
libbsd0:i386: /usr/lib/i386-linux-gnu/
libxcb1:i386: /usr/lib/i386-linux-gnu/
libxau6:i386: /usr/lib/i386-linux-gnu/
libxdmcp6:i386: /usr/lib/i386-linux-gnu/

The game also ships with one pre-compiled 32-bit library that wasn't found in my system libraries,, but that one's handled by the LD_LIBRARY_PATH.

So try installing packages for all of the above. If it works, running `LD_LIBRARY_PATH=$(pwd) ldd NecroDancer` inside the game's `game` directory should show that all libraries are found.