It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi, here's a list of fixes I applied to make the game fully playable.

tl;dr - Move game to C:, turn on Win 98 compatibility mode and disable fullscreen optimizations, force 60 FPS limit in NVIDIA Control Panel.

Detailed instructions:

1. Manually move the game's folder directly to C: (Windows) drive.

(If you installed it via GOG Galaxy and need to find the installation folder - Right click the game in Galaxy -> Manage installation -> Show folder)

2. Turn on Windows 98 / Windows Me compatibility mode for corsairs.exe file. In the same view, check the box for Disable fullscreen optimizations below. Make sure you run the game using this file.

(To access these settings, right-click the file, click Properties and go to Compatibility tab.)

3. For fast scrolling during crew battles (NVIDIA cards, AMD should have an equivalent):

a. Run NVIDIA Control Panel
b. Manage 3D Settings (left menu)
c. Program Settings tab
d. Add -> Browse -> Find corsairs.exe and add it
e. Scroll the settings down to find Max Frame Rate
f. Change it from Use Global Setting to On and set it to 60 FPS. Lower FPS might give you slower scrolling, but may also affect smoothness of the game overall, not sure. 60 works for me.
g. Make sure you apply the changes (bottom-right)!
Post edited April 02, 2024 by czubai