It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

My achievements and unlocked vehicles don't seem to save after I close the game, anyone else having this problem?
I'm having the same issue. What's weird is, if I have a saved game I can resume from it, but I can't restore the unlocked vehicles.
Same problem here. I'm on Windows 7 64-bit...
humstar: I'm on Windows 7 64-bit...
Me too.
Same issue, lost all progress. third times its happened
Happened to me too.
Post edited June 21, 2015 by Sculpy
Yep, I had just beat the game the last time I played. I load it up again and it looks like I've never played before. All stats and unlocks were wiped.
Some people keep reporting issues like getting endless loot, unresponsive scenario buttons and occasional hanging on startup/loading. DRM-free version may also have issues with unsaved unlocks.

So far we haven't been able to reproduce these issues ourselves, but all people seem to be getting the following error:

UnauthorizedAccessException: Access to the path "C:\Users\[USERNAME]\Documents\Convoy\GameStats.xml" is denied

We're not sure why this happens to some people and not to others. This seems to be an issue with user account setting in Windows, as some people have reported that running the game as administrator resolves the issue. For other people, it appears this does not help.

We currently suspect that this is either caused by incorrect user account access rights, or perhaps a virus scanner blocking access.

We currently do not have a concrete fix for this, and any suggestions would be welcome!
I'm using CCleaner, which might be "cleaning" records used by the game. This would be the first time I have ever encountered a problem with this program.

How can I run the the game in admin mode using GOG galaxy?
I am not using any anti-virus program at the moment. I also have my UAC Controls all the way down. And have also tried running and installing as administrator. No matter what i do no achivements are saved, although my continue game functions correctly.
Disabled my virus scan and UAC (plus running as admin anyway) and it didn't help unfortunately.
Post edited June 25, 2015 by Obviously
The game is installed on a system without any anti virus etc programs.
I have the same problem and it is very annoying. Is the game broken? If yes I might go for a refund.
(moved to other thread)
Post edited June 27, 2015 by henrik.wolff
Could it not be as simple as certain directory names just aren't compatible? Some non-english letters may be the problem. Have a look at people's error logs and see if there is a pattern with "bad" user names.

Also, unexpected spaces in directory names or in registry keys can sometimes produce problems like these.
So are the developers actively working on a solution to this? The fact that they can't recreate the issue themselves is troubling, but this is a major issue and it makes me not want to even play until it gets fixed.