It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hi guys!
I've been playing Commandos 3 I had bought at GOG without any trouble. I've managed to complete Central Europe campaign flawlessly. When I took up Normandy campaign, the first map went just fine, while the second (possibly the only one with prominent amount of water) renders a hideous glitch - the water seems to overflow through most of the map, including enemy soldiers walking atop - see screenshots attached below. Sadly, the scenario is completely unplayable.

I tried to follow the steps from "Commandos 3 and Windows 8 - Workarounds, Limitations, Improvements" thread (even though the symptoms described were a bit different), but it didn't solve anything. Trying to fiddle with compatibility options doesn't help either. While searching the net usually helps, this time I'm out of ideas.

I'm running Windows 10 x64, the GPU is Intel HD 4400 (more specifically, it's Asus BU201LA laptop). Has anyone of you encountered such an issue and has any idea on how to solve it?
Attachments:
No posts in this topic were marked as the solution yet. If you can help, add your reply
An interesting update.
I found an older version of GOG release on an old HDD of mine - version marked as 2.1.0.16 (I downloaded it on 2015-03-22). Interestingly, the game shares the bugs known to exist on Windows 8/10 (colour palette issues etc.), HOWEVER the aforementioned mission no. 2 of the Normandy campaign does not bear the water bug I first complained about! After a few tests, I'm certain it's actually recent update "1.42 hotfix 1" that breaks the mission.

In other words, contemporary GOG release fixes a couple of issues, yet unwittingly creates another one. We need some attention here.

If I somehow manage to work out a way to get the most of both versions, I'll post here. So far, I've notified the GOG staff of the issue.
Post edited November 08, 2018 by vear
GOG has surreptitiously (as no notification popped up) released a hotfix 2 version, which fixes the bug. I haven't checked it yet, but it seems the problem is now solved :)