It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have problems updating the game to 1.16. After I run the patch it says "Celtic Kings is not installed".

At first I've installed the game in C:\games\Celtic Kings, after that I thought about installing it to the default folder in Program Files, but it didn't help.

Anyone else having problems with patching the game? Any solutions?
This question / problem has been solved by Namurimage
You mean gog's version ? I think gog's version already is 1.16.
Damn, you are right, it's already 1.16.
I didn't know where to watch what version is the game and the Update button was red, so I supposed it isn't the latest and it wanted me to update it.

Anyway I saw that the version number sits just above the logo and it's 1.16.
To check on version numbers you can try the gog wiki, i think the version numbers are listed there somewhere.