It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
The MIP filter should be off by default, but if it's still somehow on for you, you can use the above fix or turn it off in the advanced settings.