It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Hallo at all,

did anyone tried the Linux version of Call to Power II Apolyton (https://github.com/civctp2/civctp2/) is it already playable. I would be happy to hear of peoples experiences either positive or negative.
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
deropo:
A long time ago I tried the SVN version that the git version you link is based on, and it was unplayable. Delayed graphics updates, no movies, no resolution setting in-game if not full-screen, no in-game full-screen toggle, requires writable data dir, crashes often with keyboard locked. I also had to adjust a number of files for correct case-sensitive naming.. FYI, here's my notes on the case conversion (I'm sure gog will mangle it):

# in the target linux dir:
lndir /usr/local/games/wine/Call\ to\ Power\ 2 .
# converting to all-lower or all-upper seems to cover most of them
# Enfuriatingly enough, some are also mixed-case, so all 3 should be present
find -name '*[A-Z]*' | while read -r x; do echo "${x##*/}" | dd conv=lcase 2>/dev/null | while read -r lc; do test -e "${x%/*}/$lc" || ln -s "${x##*/}" "${x%/*}/$lc"; done; done
find -name '*[a-z]*' | while read -r x; do echo "${x##*/}" | dd conv=ucase 2>/dev/null | while read -r lc; do test -e "${x%/*}/$lc" || ln -s "${x##*/}" "${x%/*}/$lc"; done; done

Maybe the newer version you link to is better. I haven't the patience to test, and diff isn't helping me see what changed. At the very least it doesn't "just compile", so if I do look at it, it will be later.
I tried this:
https://github.com/ptitSeb/ctp2

And got it to work...except it can't load games. And it crashes during games. So it doesn't work.
The one in the OP is updated more recently. I can't bother to try it now though.
Post edited May 02, 2020 by ElSketcherino
what does OP mean?
avatar
deropo: what does OP mean?
OP is an acronym of Original Post (the first post in a thread) or Original Poster (a person who started the thread).
For other reasons, I went and tried https://github.com/civctp2/civctp2 again. It's had changes as recently as last month, so I figured it was worth a shot. This time it compiled without a hitch (well, not with the recommended configure flags, but with a plain configure or a gentoo-style configure, it's fine, both 32-bit and 64-bit). Unlike all the others I've tried, it seems to work well: movies, interface, sounds, etc. In fact, it works better than wine: wine-4 and lower don't play movies, and wine-5 and higher crash when trying to start a new game. I haven't tested extensively, but I'd recommend starting with this one.