It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I'm having this issue with Caesar 3. The fire sprites are not showing as well as the flags on the Prefecture and Engineer Post buildings. Those are the main ones I've encountered so far, but there may be more. I tried it at first with the default GOG executable (I did a clean install a couple of times) and then I tried it with the widescreen resolution executable. No luck. I also tried compatibility mode for windows 98 and XP. Still not wirking. I'm running it on Windows 10. Anyone have any idea how to fix this?
Post edited September 12, 2017 by cekobidonq
Building animations not showing up is a known problem of all of the Impressions city builders, normally just restarting your PC fixes it, alongside using the widescreen patch for the game. You may find it a little difficult to find the widescreen patch for C3, but should be possible to find it somewhere.