It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hiya GOG, this is a rehash of a thread seen elsewhere on the internet, but might as well put it here too

Please note that we cannot guarantee to be able to address everything because we don’t all have the same hardware and software, but if you try running through these tips as well as provide the necessary info before posting a thread, then we might be able to help you out.

(For the fastest feedback and help from fellow players, please consider checking out the #bug_reports channel on our Discord server, as it is where we are most active.)

This section is for issues about getting the game to the main menu.

The game crashes on launch or doesn’t launch at all
Try the following:

[*]Check your graphics drivers are installed or up to date.
[*]Check you meet Brigador’s system requirements (to quickly check your CPU speed and RAM on Windows 10, press the Windows key + Pause Break key at the same time).
[*]Check that system files aren’t missing or corrupted via Microsoft's System File Checker tool (such as if you are receiving a fault bucket error)

One common issue among newer machines is that on modern operating systems like Windows 10, the system is missing certain redistributables. It's not necessary to know what a redist is, just that it's what helps a program like Brigador run. So please try the following but do not do anything - just confirm or deny the below.

[*]Click on your Start menu
[*]Click the Settings (cog/gear) icon to open the Settings window
[*]Click "Apps"
[*]You should see "Apps & Features" in the window
[*]Scroll down to see if "Microsoft XNA Framework Redistributable 4.0" is found in the list of apps or not.

If none of the above help, proceed to the instructions in HELP US HELP YOU (scroll down).

The game launches but there's something up with my display or mouse cursor
This might be to do with DPI scaling, particularly if you have a high definition monitor. Try the following, providing you are on Windows

[*]Go into the games main folder and right-click "Brigador.exe"
[*]Click "Properties"
[*]Click "Compatibility"
[*]Check "Disable fullscreen optimizations"
[*]Click "Change High DPI Settings"
[*]Check the box under "Program DPI"
[*]Check the box under "High DPI scaling override"
[*]Under that box you will see “Override high DPI scaling behavior. Scaling Performed by…”, set this to: Application
[*]Click OK
[*]Click Apply

Try launching Brigador after this.

I modded the game and now nothing works
We have Brigador Modding Documentation that both details the correct procedure step by step to install mods, and how to restore your game to its default state if you have gone a bit too far in your modding adventure.

I got the error message telling me to email support(at)stellarjockeys(dot)com
This email address now works - we resurrected it

This section assumes that the game is functional and will load to the main menu.

Levels are taking a long time to load
Please go to SETTINGS > GENERAL tab and set VSYNC to disabled. This typically improves load times. If not, please proceed to the instructions in HELP US HELP YOU (scroll down).

The controls feel weird
From Brigador’s main screen or via pause menu, click SETTINGS > GENERAL tab and scroll down to find TANK & MECH MOVEMENT and AGRAV MOVEMENT. Click to choose from one of five options for these vehicle types.

The gameplay is slow or laggy
Please check your game speed in the SETTINGS > GENERAL tab. If game speed is set to 100, please check your CPU processor speed and not your graphics card. You may attempt to disable the game’s lighting to improve performance (please refer to Section 4 of the Brigador Modding Documentation for details on changing the Rendering Control via the debug panel).
Lights can be quite computationally expensive. This means Brigador’s engine is in general, more CPU-intensive than GPU-intensive (in particular the game runs on a single thread of a CPU, meaning multitasking CPUs may encounter difficulties), and levels with a lot of lights in them are known to impact performance on some people’s machines.

I can’t get X achievement
Check that you have an active connection to the internet and that devmode is not enabled on your copy of Brigador. If you have met the requirements for an achievement, but it does not pop, try either quitting and restarting Brigador, or even closing and reopening your launcher (be sure to right click the launcer icon in your System tray on Windows), and then relaunching Brigador.
Three specific achievements are frequently asked about:
Blood Money – The 15 second timer starts after KNIFE CHASE loads, so deploy quickly to enter the loaded Campaign level.
Rock Over Solo Nobre – Make the Citadel shoot the drones, and abuse the Citadel’s slow turning radius with the agrav in between slams.
Not One Stone – Do a FREELANCE run in a Treehouse with the Ploughman/Harvester that includes St. Martim's and wipe out as much property as possible in all the freelance maps of that operation.

Please do any or all of the following depending on the nature of your problem.

[*]Tell us what storefront you purchased the game from.
[*]Send us a detailed bug report i.e. describe the conditions before the bug occurred, such as what you were doing before it happened.
[*]Send us a copy of your log.txt via (do not copy and paste it into a thread). You will find the log.on the main Brigador game folder. This file is overwritten every time you start the game.
[*]Send us your system specs in the following manner:

Operating system version
CPU model and clock speed
RAM amount in MB or GB.
Graphics card model and driver version
Display resolution used when playing game (describe windowed, fullscreen, or fullscreen windowed).

An ideal description would be like this:

Windows 7 Professional 32 bit.
Core i7 5820k @ 3.3 ghz.
32 GB RAM.
Nvidia GTX 970 driver 361.43.
1920x1080 fullscreen.

A non-ideal description would look like this:

Windows 7.
Core i7.
32 GB.
Nvidia GTX 970.

[*]Send us your dxdiag report via link (do not copy and paste it into a thread), assuming you are on Windows. This link will tell you how to find and run dxdiag:

Lastly please note that issues can be rooted in both software and hardware. By providing the information listed above we will be able to more accurately discern the likely cause of your problem.

You are also welcome to email us at team(at)stellarjockeys(dot)com with your technical difficulties.
About 20 minutes ago I started up "Knife Chase" with Leng's Mongoose. I went to use "Active Cammo," but there was no active cammo. The little HUD icon was missing, and nothing happened when I hit the fire special button. I thought "that's weird," and tried again with the Shortbus. Same thing - no EMP grenades.

I thought maybe some game files were corrupted. I got the game through GOG, so I used the "Verify / Repair" option in GOG Galaxy. After that the game wouldn't launch *at all.* So I rebooted, reinstalled the game. Still won't launch. The "Play" button turns grey, then purple again with no comment. (No error codes, no log files, no nothing.)

So I started googling; I found this thread and I also found a Reddit post about repairing / reinstalling Microsoft XNA Redistributable Framework 4.0, so I tried that. No good.

As I was poking around in the Brigador game directory looking for log files, I spotted the game executable and thought I'd try running it, just for kicks. *Now* there are some errors!

"The code execution cannot proceed because <XXX>.XXX was not found. Reinstalling the program may fix this problem." (Clearly, it didn't.)

The files are:

MSVCP140.dll (again)

I'm not sure where these files could have gone. I did not, in the 5 minutes between "the game starts" and "the game won't launch" make any change to my system, either software or hardware. Google suggests they are part of the 2015 Visual C++ redistributable package, so I'm going to try reinstalling that. Apparently I have to reboot to do that, so, fingers crossed...

<posted in mid composition - there doesn't seem to be a way to save drafts here...>

...and that seems to have worked. Game launches! However, still no special weapons in "Knife Chase." I just unlocked it, so maybe specials are disabled on purpose in that mission - without comment to throw me for a loop - and it just happened to coincide with MSVC++ being weirdly corrupted in some way?

Anyway, I have Windows 10 Pro, 2004. Reinstalling XNA didn't help, but reinstalling VC++ did. Hope someone finds this useful.
Post edited September 09, 2021 by taiji_jian
taiji_jian: About 20 minutes ago I started up "Knife Chase" with Leng's Mongoose. I went to use "Active Cammo," but there was no active cammo. The little HUD icon was missing, and nothing happened when I hit the fire special button. I thought "that's weird," and tried again with the Shortbus. Same thing - no EMP grenades.
Anyway, I have Windows 10 Pro, 2004. Reinstalling XNA didn't help, but reinstalling VC++ did. Hope someone finds this useful.
1. Yes there are certain campaign missions where your specials are disabled - KNIFE CHASE is one of them. It is by design.

2. We're aware of this problem specifically to GOG. We think it has something to do with a particular redist being deprecated in the Windows 10 operating system and generally speaking is one of the problems associated with trying to keep a game updated over the years.

This problem is compounded because even though we've earmarked the correct redist on the backend, it's apparent that GOG's redists are not as up to date with the latest from Microsoft (we've already made a ticket about it but such things take time). This is likely why when you reinstalled the game you no longer had the correct redists as you had before.

Therefore an important disclaimer if you or anyone else is having problems with GOG version of the game launching recently - affecting operating system files may end up making your computer worse. Please make any necessary backups to avoid permanent loss of important files, and proceed with caution.

With that caveat out of the way, please try downloading and installing the x64 for Microsoft Visual C++ Redistributable for Visual Studio 2015, 2017 & 2019 from Microsoft's official site

Please follow all the system instructions that Windows tells you, such as restarting your computer and only after that attempt to launch Brigador.

If this does not help, we also recommend you use Microsoft's own system file checker tool. Instructions can be read here:

Failing all of the above, feel free to email us at either the email address in the crash window or team(at)stellarjockeys(dot)com and be sure to include a log.txt, a .dmp file where applicable and as much technical specs as possible (hardware and OS)