It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Ok so I just brought BloodRayne 2 terminal cut today, and I was about to do a let's play, until of course the opening cutscene didn't play. Now luckily I've played this game before, else I wouldn't have ever known there was a opening cutscene to begin with.

Now on to the point...does anybody know how to fix this!? I saw on a steam discussion that said we should be able to play cutscenes on media player. Now I was able to do that in the legacy version MPG files, but TC (Terminal cut) only has SRT files. Now strangely enough I tried copying the video files from Legacy, and pasted them inside TC video folder in the hopes that it would work, and I even verified the files in GOG.....it didn't work.

But if I play Legacy the cutscenes play just fine, but my controls however are completely weirded out....
The select and jump button should be the A button (or X button if you're using a PS controller. But I'm using a ZD controller) Can someone also help me with that too, cause I tried going into the options but don't remember seeing anything that would change that setting.

I'm really glad I got this on a sale, cause this is ridiculous! Every time I play TC it doesn't even play the opening cutscene at all....

please someone help!
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
DemonOfOblivion: Ok so I just brought BloodRayne 2 terminal cut today, and I was about to do a let's play, until of course the opening cutscene didn't play. Now luckily I've played this game before, else I wouldn't have ever known there was a opening cutscene to begin with.

Now on to the point...does anybody know how to fix this!?
The issue with the cutscenes in Terminal Cut for BR2 is now fixed. Please ensure you are on the latest patch (1.01) – the first release of this patch on GOG had some video files (.bik) incorrectly mapped to the main directory instead of the video directory. If the issue still occurs, try closing and reopening GOG Galaxy, then verifying your install from GOG Galaxy by choosing BloodRayne 2: Terminal Cut in your library, then selecting the settings button in the top right-hand corner, then selecting Manage Installation > Verify / Repair. If this does not solve the issue for you, please reach out to us at support@zigguratinteractive.com.
Post edited November 30, 2020 by alxltz