It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Game installs fine on both Windows 7 64bit and Windows 8.1 64 bit.
Click The Desktop Icon and the launcher opens fine.

Click play and the first error I was getting was "cant find msvcp120.dll."
Googled and found out that usually relates to Microsoft Visual C++ 32bit version not being installed.
Download and Install both MS VC++ 2013 64bit and 32 bit apps.
Clicking play then gives me an error "The application was unable to start correctly (0xc000007b).
Tried uninstalling the 64 bit version of MS VC++ and reinstalling just the 32bit version. same error 0xc000007b.

Tried uninstalling and reinstalling the game as administrator. Same problem.
Game is installed on D Drive in Games folder (not a system folder).
Not sure what else to try.

OK I seemed to have fixed it.
After everything was installed
1. I uninstalled the Microsoft Visual C++ version 2012 (both 32bit and 64bit) that the game installed.
2. Then I reinstalled the game which also reinstalled both of those 2012 versions.
And the game started working...

In any case this post will help anyone else that runs into it in the future.
Post edited July 09, 2016 by tekhmaster
No posts in this topic were marked as the solution yet. If you can help, add your reply
Thanks for posting this. I had the same problem with the missing "msvcp120.dll" file and fixed it by doing some of the things you mentioned in your post.

Here are the full steps that I took to get the game to run:
1. Uninstalled MS VC++ 2012 x86 & x64 versions that Battlezone installed and uninstalled Battlezone as well.
2. Downloaded MS VC++ 2013 x86 & x64 from this link and then installed both of them.
3. Installed Battlezone again which also installed the 2012 MS VC++ apps.
4. Launched game and now it works. :D