It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Sorry, posted this before, but forgot to mark it as a question.
Hi, I'm running the Battle Isle Platinum Package on Windows XP SP3, my PC is an Athlon 2400+, 1,5 GB RAM, Radeon AGP HD 3450 graphics card. I have Catalyst 11.7 AGP Hotfix installed.
My problem: The videos in Battle Isle 3 don't play, I get no image, but sound. It shows something like IGP32 can't be decomprimied" (sorry, don't want to give the real German error message here, you wouldn't understand, I guess).

I think the Platinum package was a bad purchase, the worst one I made on so far.
I made it although I already have the CD-ROM version of the package because I wanted to be able to play those games on XP. As it turns out, it doesn't work with most of them, and I've gotten my own German version of Battle Isle 2 to run in DosBOX.

So, my other problem: Incubation lags terribly, is practically unplayable. I think this is because the glide wrapper doesn't work well. And in the gog-version you can't change to software mode contrary to my own CD-version.
Pretty badly ported, I think.
I thought it would work as well as I-WAR, where the gog-version functions pretty well (also a 3DFX-Glide game). But this is absolutely not the case. The gog version just works as bad as my own CD-ROM version with glide wrapper.
Hope gog releases some patches for Incubation, and provides the codecs you need to play those BI3 videos on the product page! Please do so, this one is the worst package you offer so far!
No posts in this topic were marked as the solution yet. If you can help, add your reply
I got something to add to this: You can consider this solved. The problem with Incubation is solved by using zeckensacks gilde wrapper and playing around with its settings (set render thread etc.), for Battle Isle 3 you need Indeo 4 Codecs.
Would be nice if they'd be integrated into the package or at least a link added to find them, took me a while to figure out what I need to play the videos, and it's pretty inconvenient that there's no hint you need them on the product page etc.