It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Are there any special settings, which should be taken when starting the game?

The game keeps on crashing before the first mission starts, it just happens when trying to play the regular game, the expansion disk starts correctly.

Any ideas?

I have the same problem. As soon as the 'pda' opens , the screen shows some kind of machine code and shuts the game down.
I can play the '2' option as well. I know the map codes from playing way back, and I tried to use those in the menu while playing the expansion game , and that doesn't work either.
Also I tried to download the game through but after downloading the 2 gb file it unpacks in the folder on the C drive !
I have been able to play the regular battle isle game with install for a couple of weeks before it started crashing, so it seems there is some problem with the way the game loads its data (maybe with the cloud?)

Also I have uninstalled the game and all the saved data, before reinstalling everything, which didn't help either
Has anybody found a solution for this issue - tested under WIn10 and Win7 and exprienced the same result.
micaic: Has anybody found a solution for this issue - tested under WIn10 and Win7 and exprienced the same result.
I have same problem when my cloud save was switch on, but I have found a sollution,

First, I've switched off the cloud save. Then I have searched the save files (e.g. GOG Games/.Battle Isle 2/cloud_saves/SAV).

If you want a fresh start, the easiest way to erase every files in this directory, and begin a new game.

If you want to continue your old save game, it is a bit trickier. First you must rename your old save file (e.g. SAVE000.dat to SAVE000.tmp) and erase or rename SAVEHEAD.dat. Then you must begin a new camapign game with the same level where you saved originally the game (under the "new campaign" menu you can type the name of the desired level). Save the game. After qutting the game you must replace the new SAVE000.dat with your SAVE000.tmp.

For me, this sollution worked.
It worked for me. Thanks so much.