}

It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Patch 2.1.63.2 (gog-4) 26 MBPatch 2.2.66.0 (gog-5) 7 MBPatch 2.3.67.2 (gog-6) 17 MBPatch 2.3.67.3 (gog-7) 2 MB

Any of these patch doesn't work, please see attachment, why?


Rgds,
Yoshi
Attachments:
You only need to install the patches if you have an older version of the game. If you're downloading the game for the first time, the main installer already includes all patches.
Thx man , that's what I thought