It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Okay so it seems like any attempt by my party to leave Beregost now crashes to the desktop. It seems to crash at the point where it changes from the "travelling" mode to the party in the new location.

I've tried going in and out of buildings (successfully )and then trying again and that didn't help. It also doesn't seem to matter which direction I head in or whether I try and go one map square or several.

While playing I've had quite a few random crashes to desktop when entering buildings or moving on the map but restarting and reloading has always let me carry on, I've had never a repeated crash like this one.

It makes me think there is something about to be triggered when I arrive at the new map area (perhaps another assassin) and it's this event that is leading to the crash.

If it helps I just beat Daevorn and started Chap.4, I went back to Beregost to re-supply before heading for BG.

Am I boned?

If I have to go back to a previous save is there something I might have done that is making this happen now? I'd hate to go back (assuming I can go back very far anyway, I quite often purge saves) and then end up with the same problem.

Very depressing.

Post edited October 17, 2011 by sandbags
This question / problem has been solved by Coelocanthimage
Sounds like it could be the infamous 'Beregost bug'. If so, you may be boned. There's a Bug Fixer you can try Here. I don't know if it works or not, as I've luckily not had to use it yet.
Coelocanth: Sounds like it could be the infamous 'Beregost bug'. If so, you may be boned. There's a Bug Fixer you can try Here. I don't know if it works or not, as I've luckily not had to use it yet.
Thanks for the link, I will try it out.

But I notice that it describes the problem as being with a saved game "resulting in a crash when you try to load them". I can load the save fine, the crash comes later.

But maybe they have the same root cause and, thus, fix. I guess I'd better hope so.

Thanks again.

One thing I noticed trawling for answers was some that about the Jovial Juggler door being responsible. In my saved game the door to the Juggler was open. Merely closing it didn't fix anything but I have gone back to an earlier save from before I left Cloakwood and in Beregost (and with the Jugglers door closed) I can travel.

I wonder if saving with the door open is what corrupts the save file.

I guess I hope so, we'll see if I can get out when I'm actually done in Beregost.

sandbags: [...]
Tell us if the fix worked. If not, I bet the save don't have to be scrapped completely yet :)
That bug usually happens in your first time leaving Beregost, but you're in Chapter 4.

I overcame this bug once by simply having my party stay still for an hour (game time, not real time) with the game unpaused, then moved to south of Beregost, and it was successful.

I believe another way of overcoming the bug is to go east to the map of the Lathander temple, then leave that map to go directly south of Beregost.

If both of those fail, then enable the CLUA commands, and use the MoveToArea command. I had to use it even in my current playthrough to get to Ulgoth's Beard, as for some reason the world map wouldn't allow manual travel there - the first time anyways. Once I got in there using CLUA, I was able to come & go as I please.
Post edited October 17, 2011 by bladeofBG
In fact I had a save that wasn't too far back so I tried again and, this time, made doubly sure the door to the Jovial Juggler was shut before saving or leaving. No problems after that.

Thanks for marking me as the solution, although I'm not sure I deserved it. I don't recall reading about that Jovial Juggler door bug anywhere before. I'll keep that in mind for my runs, as I always just leave that door open.