It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

Hi all,

I'm on Arch and have been trying to get BG to run for the past few days. I was able to get the game to launch by pointing it at the steam-runtime directory ( for the libssl1.0.0 mismatch error ). Now that the game is launching, I'm having issues with audio not playing. I'm seeing an ALSOFT error that seems to suggest the game is having issues working with pipewire/finding an audio sink. Steam seems to somehow get around this and I get audio so long as I'm not running steam-native ( in which case the game just crashes on startup ) but it's not clear to me what it's doing.

Anyone have suggestions on how to fix this/where the issue might be?

Just some additional debug info - If I add ALSOFT_LOGLEVEL=3 then I get a dump of the steps it takes to try to hook into audio. Per the debug output, it looks like it's finding pipewire then fails to actually use it, trys to fall back to pulse, fails, falls back to also and then fails to open the 'default' playback device:

[ALSOFT] (II) Found PipeWire version "0.3.70" (0.3.68 or newer)
[ALSOFT] (EE) Failed to create PipeWire event context (errno: 2)
[ALSOFT] (WW) Failed to initialize backend "pipewire"
[ALSOFT] (WW) Failed to load
[ALSOFT] (WW) Failed to initialize backend "pulse"
[ALSOFT] (II) Initialized backend "alsa"
[ALSOFT] (II) Added "alsa" for playback
[ALSOFT] (II) Added "alsa" for capture
[ALSOFT] (II) Key excludefx not found
[ALSOFT] (II) Key default-reverb not found
[ALSOFT] (II) Opening default playback device
[ALSOFT] (II) Key alsa/device not found
[ALSOFT] (II) Opening device "default"
[ALSOFT] (WW) Failed to open playback device: Could not open ALSA device "default"
[ALSOFT] (WW) Error generated on device (nil), code 0xa004
[ALSOFT] (II) Freeing device 0x55b2fcea6860
No posts in this topic were marked as the solution yet. If you can help, add your reply
so you have a Steam copy of the game... running on Linux and then you think Gog forum is clearly the best place to ask your question
ussnorway: so you have a Steam copy of the game... running on Linux and then you think Gog forum is clearly the best place to ask your question
No. I bought and installed the game from GoG and pointed it at the steam runtime to resolve the libssl1.0.0 issue. The question wasn't how to get a steam copy working on linux.
Post edited May 16, 2023 by the_corrupted
Hi, i have the same issue, Steamdeck, Gog native version without sound and this same error.
Did you find a solution ?
bolbit: this same error
As in this same Openal debug log output?

If yes, then you probably need to start with investigating why Openal tries but fails to make use of PipeWire.

I have no experience with the Deck hence I've no idea what setup it uses, first determine what is actually used for sound output by default, then work down from there. Googling along the way as usual.