It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
Does anyone know if there is a way to get the game to work with surround sound? I'm using logitec G51 speakers with a Creative Sound Blaster X-FI Extreme sound card.

Its just a pain to have to switch out of 5.1 whenever I play this game. Otherwise I don't hear any of the characters and their banter. Just the background noises.

Any help would be appreciated. Thanks.
This question / problem has been solved by anamorphicimage
avatar
geoguy2011: Its just a pain to have to switch out of 5.1 whenever I play this game. Otherwise I don't hear any of the characters and their banter. Just the background noises.
Strange, I have the same X-Fi sound card with 5.1 speakers and play BG2 without that issue. The game does not offer true 5.1 sound of course, but by enabling the CMSS-3D option in the Creative Console (switched to "Game Mode"), the sound card redirects the sound to all speakers.

You might also need to use Creative Alchemy to enable EAX effects (which is needed for DirectSound3D support in Windows Vista & 7, but not Windows XP). See the settings for BG2 here.

Otherwise, perhaps you have your speakers plugged in wrong or something.
I installed a few creative programs I had previously not had installed and that seemed to have got it working. Thanks for your help, and sorry that it took so long for me to respond.
avatar
geoguy2011: Its just a pain to have to switch out of 5.1 whenever I play this game. Otherwise I don't hear any of the characters and their banter. Just the background noises.
avatar
anamorphic: Strange, I have the same X-Fi sound card with 5.1 speakers and play BG2 without that issue. The game does not offer true 5.1 sound of course, but by enabling the CMSS-3D option in the Creative Console (switched to "Game Mode"), the sound card redirects the sound to all speakers.

You might also need to use Creative Alchemy to enable EAX effects (which is needed for DirectSound3D support in Windows Vista & 7, but not Windows XP). See the settings for BG2 here.

Otherwise, perhaps you have your speakers plugged in wrong or something.
Hello guys I need some help. I have the same problem.
Not hearing any character sounds at BG2. I cant enable/disable EAX and it seems I cannot download/find the alchemy program for windows 7
Firstly you should just open the Win7 Control Panel and make sure you have the correct settings that match your speakers (5.1 surround?)

If you have a Creative X-Fi sound card, you should have all the drivers /applications on the disc that came with it. Alternatively download the newest ones, start here, select your card and you get the list of drivers. Alchemy 1.41.02 is there.