It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

OK the error message goes:
"The instruction at 00410f5b referenced memory at 00000000 The Memory could not be written".
I think this has been suggested before but try it:

Right-click on 'Atlantis - The Lost Tales' icon and go to the 'Compatibility' tab. Tick the 'Disable visual themes' box.

I am running on Windows 7 32-bit.

After I tried this I didn't have any problems at all. I think I am halfway through the game now. I hope this works for you guys as well.
Well guys, further to my last post:-

I thought I had done what Timelegend said, but when I looked back I had a lot of other options marked as well.

I have found out, on my machine anyway, how to get this running on Win 7, 64 bit

Run the program in compatibility mode for Windows 7.

Under the compatibility tab, there are 5 settings. Only tick the central one (Disable visual themes). Leave the other 4 unticked.

Run the program as an administrator.

In case hardware makes any odds in this, I am running an Intel Q6600, with Nvidia 560.
I played a bit with the settings too and I got passed the second area I had freezes. I thought I solved the problem but now I have another freeze when leaving the second island. It freezes at the end of the final cut scene....
From my experience checking the 640*480 helps with the first guards and disabling the visual themes helps with the guards in the caves...

But now I have a new freeze! What the hell is wrong with this game???
DimitrisStr: But now I have a new freeze! What the hell is wrong with this game???
i'd rather say what the hell is wrong with GOG. Atlantis never crashed on my old P1 133 MHz.

BTW, sadly none of the solutions here worked for me, game still crashes when talking to the first guards.

I'm hoping GOG will fix that...
So do I. Hoperfully GOG will develop a patch, since most of the answers are just this partial way I found earlier, and there is noe real alternative since the game still crashes.

I tired to dig in the files, but with no succes. And I'm slowly starting to get tired of trrying.
Still FREEZES. Tried checking all except 256 colors in compability and worked a couple times, but froze again. Held ctrl,alt,del and got to task manager. Went to services and then clicked on services at bottom of screen. Windows flashed and small task manager window came up in upper left corner of screen. Then when I clicked out of the screen it wen back to the game and talked ensued. BUT, it froze again after I tried to click question of person again. It seems there is something that this game does not like that is installed on the PC.
GOG should at least give us all the courtesy and reply to all these posts and questions we ask them. They should also make good on the game we purchased. Either a fix or replacement of same or another game at same cost.
Very frustating.......
I was having the same problem, but it seemed to get better when I switched off my antivirus (Avast). Seems to have fixed it so far, no more hangups, but I've only played for an hour or so, so it's too soon to be positive.
The game didn't crashed for me when talking to the guards but it did freeze forcing me to alt tab out and kill the app from task manager.

What fixed it for me was changing the compatibility settings on the shortcut from 98/ME to Windows XP SP 2.

I'm on WIn7 64 bit.
Win 7, 64 bit.

I've started to have crashes - again: But I have a NEW solution.

I noticed that the Windows system was bitching about attempts to write to an illegal memory location.

Based on that, I copied trhe entire installation from the default directory to one outside the programefiles directory. Updated the desktop shortcut to point to the new position.

It now runs happily for me (at the moment anyway).

It would be great if somebody else could try this, but it has made a real change to mine.
Post edited July 13, 2011 by BrianUK
Namur's solution (setting the compatibility to Win XP SP 2) works for me as well, at least so far. I'm past the guards by the pool and the game has run smoothly after that.

Now the only problem is the crushing disappointment of realizing that a game I adored as a child is really a study in terrible game design.
sad to hear that there are problems with this game, its awesome but with all this crashes it will kill the interest
Here we go again.......Win 7, 64 bit.....

loads of lockups/crashes when Seth goes in search of the queen and dresses up.

I noticed that sometimes, when I went into task manager to terminate it, Atlantis started up again. Sometimes it did this if I went into resource manager.

After a lot of messing about I have ruled out anything really to do with user loaded software.

I disabled all the windows service I could, and the program ran happily except for no sound.

I gradually added services back in, and the first windows service that introduced the fault again was "Windows Event Log". I can live without that.

I decided to carry on the gentle approach of a few services at a time just in case any others caused problems, but also to get the sound working.

I got as far as "Power". With this running I got back sound, but the program started to fail again. I have no idea why Microsoft have arranged things like this, but for the "Windows Audio" service to run, the "Power" service has to be running.

So there it is at the moment - to have it running I must forgo sound and use the subtitles.

I am glad to say I also have an old laptop running WinXP 32 bit. Atlantis runs perfectly on that, so at least I can play the game there.

I really can't see why there seems to be this service "hang-up" problem, and then only with Win7-64 bit.

Thats the end of the investigating for me. I don't have the skill (or the inclination) to try and debug a service type of glitch in Win7-64 that only seems to appear with Atlantis (and most of the time it is an interaction with the guards that does it).

In case anybody is interested, I have also caught the occasional error message relating to Atlantis trying to read from memory outside its allowed address space.

Bye bye and off to the laptop.

I have the same problem, newly installed Win 7 SP1 64bit.

I don't think that it's really ok for GOG to re-release a game and claiming it to work under WIn 7 when it infact doesn't. If they doesn't fix this there should be refunds going out.
Sweeler: I have the same problem, newly installed Win 7 SP1 64bit.

I don't think that it's really ok for GOG to re-release a game and claiming it to work under WIn 7 when it infact doesn't. If they doesn't fix this there should be refunds going out.
ya like i said earlier the way they have not at all replied here is shocking :O from what i have seen the game does not work for anyone at all[no love for Atlantis here :( @gog ]