It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

I have a new laptop with drivers and directx that are completely up to date. Assassins Creed worked the first few times I tried it on a fully updated system but no longer works. I haven't changed anything since except install and play other games although I have reinstalled stuff to try to solve the problem (I only use Windows for games). The error I get relates to directx 10 (and 9 when I try it). I can't quote the precise error because now it only flashes it. Strangely, although it doesn't work with the dedicated graphics card it does work with the integrated Intel one, albeit with very poor frame rates. Assassins Creed 2 works on the system with no problems and this game is the only one I've had problems with.

I7 3610qm
8gb RAM
gt 650m (optimus enabled)

Any ideas guys? Thanks in advance.

Edit: Error code

Problem signature:
Problem Event Name: APPCRASH
Application Name: AssassinsCreed_Dx10.exe
Application Version:
Application Timestamp: 48067113
Fault Module Name: AssassinsCreed_Dx10.exe
Fault Module Version:
Fault Module Timestamp: 48067113
Exception Code: 80000003
Exception Offset: 0076d452
OS Version: 6.1.7601.
Locale ID: 2057
Additional Information 1: 0a9e
Additional Information 2: 0a9e372d3b4ad19135b953a78882e789
Additional Information 3: 0a9e
Additional Information 4: 0a9e372d3b4ad19135b953a78882e789
Post edited July 07, 2012 by Glaere
No posts in this topic were marked as the solution yet. If you can help, add your reply