It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

(typo in title which I cannot edit: read Temple of Akbaa)

I was proceeding with that quest when I realised that ALL spells were now fizzling.

It happened after I went to look at the area which I cannot go through yet, with the warning at the door about magic forbidden inside; I realised it because I then tried the Lich again, and this time neither of us could cast spells: all fizzled, making the lich easy to kill as this was its only form of attack.

From this point on, even going back to different map or restarting the computer has no effect on this, spells fizzling has become permanent; since my character is a caster with hight Int, that is rather annoying... Furthermore, going on this way has the added result that nothing happen when arriving in the sacrifice room, blocking the game story line.

I kept a save showing this bug, and I am now backtracking to an earlier save before the fizzling problem appeared (not going in the area past the blind preist before I deactivate the security, this time)


After progressing cautiously back to the same point from a previous save, I asserted that this is an issue with triggers not detected:

- Spells start to fizzle when you enter the 'no magic' room - That trigger ALWAYS work.
- Exiting that room on either end is supposed to trigger magic to working again; I never got that trigger to work when going back to the entrance side, but I got it to work when going towards the sacifice room (both on replay and with the original save which was in permanent fizzle mode).
- Whatever I try, I cannot get the trigger for the storyline to progress in the sacrifice room; I have a save showing the room fully explored as well as the 2 areas past the hangings, with the situation having not progressed.

Unless I can find this trigger, this is end game for me this time around.
Post edited October 19, 2012 by Fafhred
No posts in this topic were marked as the solution yet. If you can help, add your reply
Hm, I can't seem to reproduce this with Arx Libertatis 1.0.3 - both entry and exit triggers work just fine. Can't test if the story progresses as I don't have a save that early in the game anymore, however it worked before. I also don't see anything wrong in the 1.21 scripts here, but they aren't easy to follow. A couple of pointers:

1. If you installed AF from the CD and not make sure to install the official 1.21 patch - this fixes a lot of script bugs. For Arx Libertatis the patch needs to be installed first as the AL installer copies the data files - or just run the AL installer again after installing the patch.

2. This game doesn't have continuous physics so it can sometimes happen that you jump past script triggers if the game runs slow. This is made worse by a bug that causes the player to speed up sometimes. Try walking as slow as possible and see if that makes the triggers fire.

3. If nothing else helps, you can cheat and turn the magic back on. Follow this post - just replace the inventory playeradd line with magic on
I installed Arx Fatlais from the original distribution disc, then the ptach 1.21 English (both a few months ago). At this point the game would not start at all.
When I discovered Arx Liberatatis last week, I installed their patch 1.21 International as requested, before Arx Libertatis itself.

Walking as slow as possible is not possible, the game does not let me walk as such; movement can only be described as a succession of horizontal jumps to an uncontrolable distance.
I just looked at the bug report you linked, it is exactly this, but for me it is permanent.

At this point I had managed to get the magic back on, but not to find the trigger for the storyline event in the sacrifice room.

I have not been back on the game yet today, will try again a bit later or tomorrow, as well a s getting you 2 saves for the other bug report.
Post edited October 20, 2012 by Fafhred