It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
arrow-down2arrowcart2close4fat-arrow-leftfat-arrow-rightfeedbackfriends2happy-facelogo-gognotificationnotifications-emptyownedremove-menusad-facesearch2wishlist-menuwishlisted2own_thingsheartstartick
After spending the $5 on Steam and getting a game that was choppy as hell and stuck on V1.18, I decided to spring for the GOG v1.19 one and I have to say, what the hell?! I'm sorely disappointed!
Problem #1: Any time anything appears on the screen that uses text (like when choosing settings outside of the game), the framerate plummets to an abysmal 5fps or so. In the dungeon itself, framerate is no longer an issue, but now I get other problems much worse. (see below)
Problem #2: When I walk, a SHOOT to the next wall at warp speed! Finally the framerate for looking around is at a solid fixed 60fps-- but I have no control.
Problem #3: While the dungeon itself is smooth and silky (no more problems with lights through the wall anymore either), ALL the animations act like I'm getting 5fps (I am still at 60fps though)! When the goblin attacks it's all jerky and skips many frames, same with the movement while spellcasting.
Problem #4: And this is the killer-- the pathing for the NPC in the other room is totally screwed up. He tries to walk through the bars after talking with me, and gets stuck.. So when I opened the latch to let him out, the game went into cutscene mode and required I alt-tab out and kill the process to get control again.
Plus another oddity.. When I started the game at 1920x1200, the UI wasn't scaled to the resolution like it is on the v1.18v (which I prefer), but when I exited and reloaded the game, it was scaling to the resolution again.
Here are my PC stats:
E8500 Core 2 Duo 3.16 Ghz CPU
Gigabyte GA-EP45-DS3R BIOS F8
8GB OCZ Platinum 4x2gb 1066Mhz
EVGA GeForce GTX 260 FTW Edition
2x 640GB Western Digital WD6400AAKS HDDs
Windows Vista Home Premium 64-bit SP1
All 3D settings in the NVIDIA control panel are set to the defaults. (Application Controlled, No AA, AF, forced V-Sync, etc.)
I can't win for losing with this game.. the PC I had at the time it was released was waaaay too slow to play it, this one seems to be way too fast. :(
It might be a problem with your dualcore system. Run the game with affinity set to one core (from the Task Manager, right click on the game executable, click Affinity and untick CPU1). Or run the game with RunFirst.
You can fix the text slowdown by editing the cfg_default.ini and changing the forcegdi=1 to forcegdi=0.
Unfortunately neither one of those have any effect on the game.. The best working version of Arx seems to be the old demo!
I had a similar problem on another game. If you're running Vista you may have to play around with your power settings. It has to do with the game not being able a dual-core processor. I managed to solve the problem on my laptop by changing the settings to optimal and downloading RunFirst. Of course, it chews through my battery life, and you're obviously not running a laptop, but maybe that will help you.
Have same problems with game performance.
Vista 32 home....
What's wrong with this version of game???
fixed:
You can fix the text slowdown by editing the cfg_default.ini and changing the forcegdi=1 to forcegdi=0.
Not helping + give problems like not showing invtentory of barrels, mobs and etc, sometimes need to click 5-8 times on it to show it up.
t might be a problem with your dualcore system. Run the game with affinity set to one core (from the Task Manager, right click on the game executable, click Affinity and untick CPU1).
Helps, run like speedy devil. But still when u generating a charachter or open book it's like 5 fps.
Post edited February 28, 2009 by h0w1er
No problems here and I am on WIn7 with a crappy integrated graphics card. I have yet to notice any bad frame rate problems. Have you all done the common solutions like updating drivers and such? I am not trying to insult anyone merely asking.
I just wanted to say that I have exactly the same problems, and a very similar system -- just a bit older and slower. Slower Core 2 Duo, and slower GeForce 8800. Tried everything suggested. It is interesting how the framerate itself is fine. Looking around is smooth. Anything more than that...problematic.
I would say that it has to be something with the CPU, but changing the affinity doesn't help. It's almost as if the game expects to have all the power of both cores, but will only use the power of one. Maybe there's a way to trick it.
I'm going to try it on my laptop when I get a chance. It's similar in specs, though, so I don't know if the results will be any better.
EDIT:
Okay, mine's working now. I had written this long thing about it, but I wasn't quite right, so here's the revised version.
I decided to try disabling one of the CPU cores. First, I ran msconfig.exe, clicked on 'Boot' then on Advanced Options. The box to select the number of processors was checked, and 2 was selected. I set it to 1, restarted, and the game ran fine!
At that point, I didn't even want to play anymore. I decided to switch back to two cores. I went back in, UNCHECKED that box, and restarted. Just for the hell of it, I ran the game again, and lo and behold, it worked even better. Monitors verify that both cores are in use.
So my suggestion is to see if you have that box checked, and if so, uncheck it and restart. The system should default to using all cores anyhow. If the box is already unchecked...I don't know. Run through what I did, maybe, even though I don't know what else it could have been, except for the simple act of restarting.
Post edited April 12, 2009 by Rallion
EDIT: Just saw the OP has 64 bit Vista.
I have no solution, sorry :{
Post edited April 14, 2009 by CymTyr
Rallion: thank you for your advice! It really helped to me. Although I had that checkbox already unchecked, so I switched to single core, restarted, runned the game, unchecked box and restarted again; and I cannot imagine why and how, but it works :-).
I just hope AF will stay playable after next reboot.
I got this game free with a motherboard and that copy works perfectly fine start to finish for me, and that was on XP SP2, but might just be how GOG packaged the game that screwed it up I guess.
MCZ: It stayed playable for me through a couple restarts. Really strange stuff. I have no idea why doing that would help. I can only assume Windows is doing something weird.
Hey guys, have the same lag issue as OP, i've played with the settings and it's definitely some kind of font scaling issue - when in 1024x768 game runs without noticeable lag, however as soon as I switch to widescreen resolution any occurences of font on the screen lead to the unacceptable lag (bad on 1280x800 and worst on 1920x1200). Even the scrolling text in the cutscenes are lagging, depending on the amount of text on the screen (single lines scroll smoother).
This really sucks, for example, in combat, when you have something written appear on the screen, you cannot really fight until the message goes away. When you open the journal to increase your stats, framerate falls from 60+ to 5 fps. GOG please do something about it, will you?
My rig is:
Core i7 940 (8 logical cores, tried disabling all but one, didn't help).
Geforce GTX 280
Vista 64.
Post edited April 28, 2009 by Cheeky
avatar
UrielDagda: Unfortunately neither one of those have any effect on the game.. The best working version of Arx seems to be the old Xbox version!

Fix'd
I have the same problem with my laptop:
Processor dual core T7530
4 GB RAM DDR2
Ge Force 9600M GT
Vista 32bit
Game runs smootly (a bit too fast but not unplayable) but I have like 5fps on menu and on the book screen (and character creation).
I also had white head but I solved that by editing a parameter in the config file.
I'll try this reboot thing and let you know...
EDIT: Looking onver the Internet, it seems a GeForce problem, not a Processor one...
Post edited February 15, 2010 by happy_emi
I tried the reboot thing and it worked: I can now move at normal speed, but I still have problems:
1) When I jump I still have a very FAST jump
2) Huge FPS drop when text is displayed (drops from 45-60 to 8-10 fps). This includes character sheet, dialogs and journal. Changing force gdi didn't help
It's playable tough but I think I'll wait my next PC with a radeon maybe :P