It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

This happens randomly. I came back to the game and now when I start a new character or change maps on any character the game will randomly load my main thief build in a black box that I can't see any part of the map in.

At first I thought it was a one time glitch but it's happening frequently. I use 1.21 and an unofficial patch. Don't see why those would be the problem since it worked fine a few months ago. Example of the glitch
Reacently found out that the game relies on a current save to load levels it seems...

I just tried to load the character that it keeps loading and it loaded fine. Whenever I should try to load a different save then it would start to load this save instead of the one I picked.

After some attempting at loading the right level, I removed all my saves and put them in a folder on my pc temporarily to try out what it would do. Now, going to the Goblin Basement (down the hold in jail) I'd just wind up in a black box... When I look up or down no level is displayed. My fists and feet cannot be seen. I cannot properly move and my backpack open and close movement is very slowed down... Creepy.

I've tried my steam version a few times but it wont launch because that stupid Steam.dll is missing again.

If anybody knows of a fix then please let me know!

Try Arx Libertatis. This is more up to date than Arx Fatalis Fixed and has many more improvements.

As for the Steam version this thread describes that very problem and a possible solution. Arx Libertatis will also work with the Steam version so is another viable solution.