It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Did a short test at the local airport (ELM) and it worked fine so far. Started a blank game as "TEST ME" and did a short run around the Sewers map as an alien by myself. Worked well.

The airport connection is a Wi-Fi with about a 500 to 800 connection.

Also did another at my house with "TEST ME3" and the sewer map and alien again and Verizon DSL at about 150 to 230 connection and still no problems detected.

edit2: oops, my system specs for those interested Current pooter = Compaq CQ-56 Laptop, Windows 7 Home Premium, 2.2 Ghz Intel Celeron Processor, 4 GB RAM, 1 TB Western Digital hard drive, HP DVD+-RW DVD ReWriter, 64MB Intel video card, SEC4151 LCD display, RealTek sound card, RaLink RT 5390 WiFi, Network Plug and Wireless LAN, Lexmark 1200+ printer, HP Web Cam, ONN USB Keyboard, 3 TB Toshiba Canvio USB Desktop Drive, Logitech USB Mouse, Microphone, Merkury battery powered external speakers, connector doo dads, (yadda yadda yadda...)
Post edited October 21, 2014 by TheeAceMan