It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I just installed new drivers last night, but for some reason SLI refused to work in the game. I reinstalled the same drivers today (go into custom/advanced and pick Clean install) and then re-enabled SLI and now it works. I have no idea what changed or why it didn't work before (I definitely had SLI enabled last night, too), but its working for me now.

So, just a heads up to all SLI users, don't give up on the game right away if it isn't working. Play around with disabling/reenabling SLI in your Control Panel and if that doesn't work then try doing a clean install of the latest 296.10 drivers. That should get you up and running. Hope this helps!