It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

This thread is for anyone like me who has tried all 3 different types of download methods and it always fails before it finishes.

What could it be aside from the ip routing problem? Maybe we'll be able to find out.
No posts in this topic were marked as the solution yet. If you can help, add your reply
I cant download the damn thing ether. DL'ing getting stuck after dl'ing 25-35 megs. Tried many times - same results. Damn it GOG, cant we simply have a torrent, magnetic link or something? I get it that you are trying to push your galaxy thingie on people, but last time I tried it it caused me tons of grief, so I'll stay away from it as if it was a plague.
If you go to the forums for most GOG games you will find a thread or two very much like this one. In most cases your problem can be solved by one of two things:

1) Disable your AV and try it again. It may be that your AV is scanning each piece of the game as the installer unpacks it.

2) Just let the installer sit there for several hours or overnight, even if it seems to be stuck. It will probably complete the installation if you give it an absurd amount of time.
Post edited February 27, 2016 by alcaray