It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hi all,

During our last update we forgot to include a few files which messed up the Zhur map. Today, we have included a Universal update that will fix that problem AND an updated installer with those files all ready to go :)

Sorry about the mix up and thanks for your patience :)
Nice. I love the fact that after all these years we are still getting fixes for games like this one. :)
Okay so do I need to download the game and the patch or just the patch?
avatar
tinyE: Okay so do I need to download the game and the patch or just the patch?
if you have the previous build (2.2.0.14), the patch is enough.
Post edited May 13, 2014 by Thiev
avatar
tinyE: Okay so do I need to download the game and the patch or just the patch?
avatar
Thiev: if you have the previous build (2.2.0.14), the patch is enough.
Thank you. :D
Thank you GOG for still working on this game. Devs messed it up, and you are fixing it.

And the game is worth it. One of the best fantasy RTS games ever made.
avatar
Zacron: Nice. I love the fact that after all these years we are still getting fixes for games like this one. :)
so 1.03 is correct? Because the patch says version 2.15.14 or something but the in game it says 1.03. Also it doesnt work on my desktop but does on my laptop, i get a Font error on my desktop.
avatar
JudasIscariot: Hi all,

During our last update we forgot to include a few files which messed up the Zhur map. Today, we have included a Universal update that will fix that problem AND an updated installer with those files all ready to go :)

Sorry about the mix up and thanks for your patience :)
Game is not working in Windows 10 Pro x64. The process shows up briefly and then shuts down with no error message. Nothing shows on screen at all.
avatar
JudasIscariot: Hi all,

During our last update we forgot to include a few files which messed up the Zhur map. Today, we have included a Universal update that will fix that problem AND an updated installer with those files all ready to go :)

Sorry about the mix up and thanks for your patience :)
avatar
BadManiac: Game is not working in Windows 10 Pro x64. The process shows up briefly and then shuts down with no error message. Nothing shows on screen at all.
Please send us a Support ticket with your DxDiag attached so we can investigate the cause of this :)
avatar
BadManiac: Game is not working in Windows 10 Pro x64. The process shows up briefly and then shuts down with no error message. Nothing shows on screen at all.
avatar
JudasIscariot: Please send us a Support ticket with your DxDiag attached so we can investigate the cause of this :)
Coming right up :)
Ticket number DBZP0M2L Thanks for your quick response.
Post edited August 29, 2015 by BadManiac
Used to love this game, bought it on GOG a few years ago now, and have never been able to play it. Tried every compatibility mode when I was running Win7 but never had success. Updated recently to Win10 and thought I'd give it another shot... downloaded the new game package and installed it, tried XP compatibility, set to run as admin, have tried with both graphics engines... yeah, no such luck. Win10 64bit Home.
Attachments:
wbc3_err.jpg (236 Kb)
wbc3_err1.jpg (309 Kb)
dxdiag.jpg (358 Kb)
dxdiag1.jpg (341 Kb)
dxdiag2.jpg (341 Kb)
avatar
Dwarfurious: so 1.03 is correct? Because the patch says version 2.15.14 or something but the in game it says 1.03. Also it doesnt work on my desktop but does on my laptop, i get a Font error on my desktop.
I assume it means that this is, alike to the 2.2.014 installer mentioned in the previous sticky, a "vanilla" 1.03 install without any of the unofficial patch-series applied?

Now my questions:
a) quoting from that mentioned stickies first post " fixed to work without the unofficial patch" means we can run the game with more then 3GB main memory and without using XP compatibility Mode set?
b) could the 1.03.24 patch (GoGs Version of 1.03.23) mentioned in this post by Petrell be applied streight on to the current GoG Version, or does it now depends on the unofficial 1.03.2 patch as the "regular" unofficial patch series?
c) if (b) doesn't need the 1.03.2 uopatch, could the uopatch 1.03.25 (or any version that is to come thereafter) be applied unto it, or would it be better to go from a plain 1.3 install to 1.03.2 to 1.0325(+) in that case?
Post edited November 17, 2015 by Sha_n_Dra