It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Is there a way to reconfigure the sound in the Dosbox package to reflect the sound effects from the game? I hear midi piano every time I take a step.
I'd rather hear the old Sound Blaster music as well.
Please help.
You may try various options in the dosboxULTIMA1.conf and dosboxULTIMA2.conf, and then, the sound config files in UNDEROM1\DATA and UNDEROM2\DATA, but the sound should play properly on the default settings (beside the music).

[edit: fixed link]
Post edited August 23, 2014 by Arteveld
avatar
Arteveld: You may try various options in the dosboxULTIMA1.conf and dosboxULTIMA2.conf, and then, the sound config files in UNDEROM1\DATA and UNDEROM2\DATA, but the sound should play properly on the default settings (beside the music).
Thanks very much Arteveld. The sound does not play properly on the default settings. My Ultima1.conf seems to reflect SBpro1 as the default, but the game is defaulting to Midi (I am assuming mpu401) for music *and* sound effects. I'll try your other suggestion of choosing the music card (from the other thread) but my default settings have all sound effects using mpu401.
avatar
OriginMuseum: Thanks very much Arteveld. The sound does not play properly on the default settings. My Ultima1.conf seems to reflect SBpro1 as the default, but the game is defaulting to Midi (I am assuming mpu401) for music *and* sound effects. I'll try your other suggestion of choosing the music card (from the other thread) but my default settings have all sound effects using mpu401.
I've been playing around using sb16 and sbpro2, but then i didn't get speech [in the intro].
You might experiment with the second line in the CFG file, mine is "2 7 220 1 speech", especially with the first number, which is "soundcard ID".
Hope You'll get it running fine, good luck, have fun. [/me is off to bed, 4:4AM here;)]
Hell, except for the voice on the intro of Underworld one, I am getting No sound at all...........
avatar
OriginMuseum: Is there a way to reconfigure the sound in the Dosbox package to reflect the sound effects from the game? I hear midi piano every time I take a step.
I'd rather hear the old Sound Blaster music as well.
Please help.
Ugggh, what happened to you GOG and your DOSBox skills? :)
Unfortunately, the GOG package does not let you use uwsound.exe intuitively - the program that came with UWs and that let you reconfigure the sound devices.

To cut a long story short, to make it play UW2 music more correctly (and I assume the sound plays better too, at least I can hear it there), edit the file uw.cfg in UNDEROM2\DATA and replace this line:

5 -1 -1 -1 sound

with this:

2 7 220 1 sound

Hope this helps :)

EDIT: By the way, just tested this with UW1 and it helped a ton too (replaced "6 -1 -1 -1 sound" with "2 7 220 1 sound" (no quotation marks) in uw.cfg in UNDEROM1\DATA.

Eh, I wish they just let people use the good old trusty uwsound.exe to configure the sound - yeah, so what if it's a console utility with text UI? I use console utils on Linux on a daily basis and never complain. And it's better than leaving the customers with games that have crippled sound, no? :)
Post edited June 03, 2011 by Agetian
avatar
Agetian: Eh, I wish they just let people use the good old trusty uwsound.exe to configure the sound - yeah, so what if it's a console utility with text UI? I use console utils on Linux on a daily basis and never complain. And it's better than leaving the customers with games that have crippled sound, no? :)
They shouldn't have to give you the setup utility. The game is packaged with DosBox - an emulator. They should configure the game and DosBox to work together.

Put your posts above in a support ticket - GOG should fix that.
Post edited June 03, 2011 by lightnica
high rated
Good suggestion.

Yes the sound is messed up. Ultima Underworld supported Roland MT32 MIDI not the General MIDI set which the DOSBox can support. Unfortunately the UW configuration is set up to use MIDI for music and sound effects, and so you get both of these wrong and for both UW1 and UW2.

I have a version of DOSBox that has MT32 support and it plays Underworld music and sound effects correctly.

So short of having the MT32 capability, the correct sound track and effects in this GOG release can only be obtained through changing uw.cfg in underom1\data and underom2\data to the following

4 -1 -1 -1 sound
2 7 220 1 speech
0 cuts


4 for sound corresponds to SBPro (3 is Sound Blaster, 2 is Adlib, 6 is Roland MIDI) and -1 entries are for default settings which are set to match.

2 for speech also corresponds to SBPro (the only other option is 1 for Sound Blaster)

Since the dosbox conf files are set up by GoG to use SBPro, using that setting in uw.cfg works by default.
Post edited June 03, 2011 by noman
avatar
lightnica: They shouldn't have to give you the setup utility. The game is packaged with DosBox - an emulator. They should configure the game and DosBox to work together.
Put your posts above in a support ticket - GOG should fix that.
Well, they should but they didn't. :) I might submit the ticket, yeah.
And also, the setup utility would still help a ton - I mean, there are so many things that work for some users but don't work the same for the others when using DosBox that being able to reconfigure the sound output and such is almost as essential for some games as being able to configure the video output (which is done through GOG's "Graphic Mode Setup" tool. Would have been nice if it offered sound configuration options for advanced users or users with non-working sound as well.
Post edited June 03, 2011 by Agetian
Using the default GOG settings, you get fully digital sounds, like doors that creak open and such, but also that random piano when you walk.

Using the fix above gets rid of that piano sound, but also the digital sounds, so sound effects are just bad midi sounds. :( (this is in UU2 only)

Is there no better solution?
Post edited June 04, 2011 by Dezzy
avatar
Dezzy: Using the default GOG settings, you get fully digital sounds, like doors that creak open and such, but also that random piano when you walk.

Using the fix above gets rid of that piano sound, but also the digital sounds, so sound effects are just bad midi sounds. :( (this is in UU2 only)

Is there no better solution?
Hmm strangely, for me the above-mentioned configuration actually both fixes the music and the piano sound *and* keeps the digital sound - well, that only proves the idea that DosBox needs to be fine-tuned sometimes for each particular system... Well, you can experiment with that line in uw.cfg and try other sound devices, so basically change it, step by step, to one of the following:

2 -1 -1 -1 sound
3 -1 -1 -1 sound
4 -1 -1 -1 sound
5 -1 -1 -1 sound

and see if any of it produces the desired output for you. If not, maybe try playing with the sound card settings in the DosBox configuration file (dosboxULTIMA2.conf for UW2, dosboxULTIMA1.conf for UW1), and see if maybe changing 'sbtype' to sb1, sb2, sbpro1, sbpro2, or sb16 does anything to fix your issue.

Also, since you're getting issues with random MIDI playback kicking in, maybe try changing 'mpu401' from intelligent to uart or none in those DosBox configuration files as well, and see if that makes it any better.

It's a good idea to make backups of both uw.cfg and the DosBox .conf files before modifying them so you can revert to the original settings easily.

Please let us know if any of it solved the issue for you.
Post edited June 05, 2011 by Agetian
This is a fairly important issue and this topic should be stickied or the config should be changed on the back end. It's not gamebreaking or anything, but this is clearly an occasion where Sound Blaster sounds way better than the Roland card. I would go as far as to say "Dramatically better"
avatar
ArbitraryWater: this is clearly an occasion where Sound Blaster sounds way better than the Roland card. I would go as far as to say "Dramatically better"
Just to clarify, this is not a problem with the game's own Roland implementation but rather how it works under DOSBox. DOSBox doesn't handle Roland directly yet, instead pushing the MIDI data to a real (or emulated) Roland card on your system; if you don't have one it will be handled as generic MIDI instead with unpredictable results.
avatar
Arkose: Just to clarify, this is not a problem with the game's own Roland implementation but rather how it works under DOSBox. DOSBox doesn't handle Roland directly yet, instead pushing the MIDI data to a real (or emulated) Roland card on your system; if you don't have one it will be handled as generic MIDI instead with unpredictable results.
Yes, the game's Roland MT32 support is great. In fact, it's the best way to experience the sound. This is how I am playing UW1 from the GoG release (replaced DOSBox with gulikoza version, and copied the MT32 ROM set) The music sounds great as expected but even the sound effects (opening doors, running water streams, swish from weapon, footsteps etc) come out much improved, compared to the SoundBlaster/Adllib version.

In any case though, since standard DOSBox doesn't support MT32 (and the ROMs are hard to find with a dodgy legal situation to add), running the game with SoundBlaster config is the best way to get the accurate sounds.
avatar
noman: [...]
Yes, the game's Roland MT32 support is great. In fact, it's the best way to experience the sound. This is how I am playing UW1 from the GoG release (replaced DOSBox with gulikoza version, and copied the MT32 ROM set) The music sounds great as expected but even the sound effects (opening doors, running water streams, swish from weapon, footsteps etc) come out much improved, compared to the SoundBlaster/Adllib version.
[...]
Yes, it sounds really great. I'm using the stand-alone mt32 emu Munt under Linux with Dosbox. UU uploads samples to the mt32 for the sound effects.