It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Fan-patch for UFO: Aftershock:
Changed: Removed the DVD check from game
Changed: You no longer fail the defence mission if all militia units get killed
Changed: Reduced the commando equipment speed bonus from 1.9 to 1.4
Fixed: Cultist Code mission now appears properly even if the player has conquered all Cultist bases
Fixed: Failure to complete the first Starghost mission no longer renders the game unwinnable
Fixed: Speed bonus for 3rd level commandos is now active only when equipping a commando weapon
Fixed: Throwing knives and shurikens are now working correctly
Fixed: Pillar of Death now spawns properly
Fixed: It's no longer possible to use certain items without researching their handling techs first
Fixed: The game now recognizes looted and manufactured items properly and updates the research prerequisites accordingly
Fixed: Factory sorting in the Manufacture screen now works correctly
http://forum.altargames.com//index.php?showtopic=9557

Unofficial 1.3 patch in official Aftershock site
Post edited April 09, 2011 by ERISS
avatar
ERISS: All hail PetteriB!
Changed: Removed the DVD check from game
Changed: You no longer fail the defence mission if all militia units get killed
Changed: Reduced the commando equipment speed bonus from 1.9 to 1.4
Fixed: Cultist Code mission now appears properly even if the player has conquered all Cultist bases
Fixed: Failure to complete the first Starghost mission no longer renders the game unwinnable
Fixed: Speed bonus for 3rd level commandos is now active only when equipping a commando weapon
Fixed: Throwing knives and shurikens are now working correctly
Fixed: Pillar of Death now spawns properly
Fixed: It's no longer possible to use certain items without researching their handling techs first
Fixed: The game now recognizes looted and manufactured items properly and updates the research prerequisites accordingly
Fixed: Factory sorting in the Manufacture screen now works correctly

http://forum.altargames.com//index.php?showtopic=9557

Is it tested to be GOG-compatible?
avatar
ERISS: Changed: Removed the DVD check from game
avatar
Elwin: Is it tested to be GOG-compatible?

Don't worry, it won't add a DVD check if you already didn't have one on your version..
To test by yourself , make a backup of your 'Profiles' folder and install the patch...
At worst you'll have to reinstall the game and the folder, but it shouldn't be.
The patch should be savegame compatible too (You don't have to restart a game).
Post edited March 11, 2010 by ERISS
Could you ERISS add "UFO: Aftershock" to the topic subject or at the beginning of your first post?
You can also download the patch from here: The Patches Scrolls - UFO: Aftershock
Post edited March 11, 2010 by Sotamarsu
Hmm not a lot of details on the patch.
Anybody know if it works on the GOG version?
I figure I'll find out on my own one way or another...just looking for a little heads up if it's there.
Post edited March 14, 2010 by zebber
You can find it at Aftershock's Altar website too.
http://www.ufo-aftershock.com/pages/support.html#patches
Who knows, maybe Altar hates GOG and the patch they put on their site doesn't work with?
At least it works with my GOG version. With yours I can't tell.
I'm not a GOG official to tell you it's officially fully compatible with the GOG version.
If you fear about this patch made for free by some very few fans, just don't use it.
Post edited March 15, 2010 by ERISS
avatar
ERISS: At least it works with my GOG version. With yours I can't tell.

Thanks, that's all the info needed. It's not about fear, it's about uncertainty. For an example, there might be some additional tricks applied by GOG to make game more compatible (through wrapper or something) which get broken if we use additional patches.
Glad to hear it works.
avatar
Elwin: Glad to hear it works.

Some say it doesn't work, but it's not with a GOG version.
We don't know, for now, wether it actually comes from the patch or from the graphic driver (I don't thinks it could comes from other thing).
If there is a bug in the patch, it would not really comes from the fan work: the bug should be already on the weird official Trilogy Aftershock version the patch is based on.
So, as we didn't identify yet where the said-crash comes from, a GOG Aftershock may not work too. But mine is ok, it was my graphic driver which broke it.
As since there is still some uncertainty, test on your game if you want to be sure.
Post edited March 15, 2010 by ERISS
avatar
zebber: Anybody know if it works on the GOG version?

With soon 6 months of people using the patch without shouting after it, we can say the 1.3 fan-patch works good with the Aftershock from GOG (and maybe all other versions too).
Post edited August 16, 2010 by ERISS
Even, DotEmu sells Aftershock directly patched in 1.3!
Maybe that's 1C which gave them the game in 1.3?
However, patch 1.3 was already on dev' website (even told Unofficial),
and as now it is sold with, we can say it is officialized.
Post edited July 06, 2011 by ERISS