It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

Hello guys I have just re installed the witcher 2, put it on max setting the system specs I have are.

Intel i5-3570k CPU @ 3.40GhZ 3.80 Quad Core
8GB Ram 1600mhz
Geforce GTX 680 4GB
Windows 7 64 Bit
I have the 306 nvidia drivers installed

Bit annoyed as I can run GW2 in some areas over 100fps lowest I had was 40fps thats with everything maxed.

any ideas guys?

edit. just went on the game changed from ultra to high and there is a 35fps increase just crazy.
Post edited December 31, 2012 by Septim69
Septim69: any ideas guys?
Ubersampling. If you put it on max, then ubersampling is on. It's an antialiasing method that was added more for the sake of making the game look better on future hardware than being realistically possible on current hardware; it's virtually impossible to make it work on a single GPU (unless you run it at a lower resolution), really only being realistic on the strongest Crossfire/SLI setups.

If you turn everything to max and then turn off uber, the game should run much better and be a bit prettier than the high settings.