It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I was forced to install this. The first time I tried not installing that and got some message about a missing file whenever I tried to run this game. So I reran the installer and let is install 9.0c and the game worked.


Does this overwrite my DirectX 11, or whatever it is now, files?
avatar
Generalelectric: I was forced to install this. The first time I tried not installing that and got some message about a missing file whenever I tried to run this game. So I reran the installer and let is install 9.0c and the game worked.

Does this overwrite my DirectX 11, or whatever it is now, files?
No; it's in addition to DirectX 11. Now your computer will run both games that require DX11 and games that require DX9.
I thought they were all backward compatible.
avatar
Generalelectric: I thought they were all backward compatible.
DirectX 10 was the point where full backward compatibility was broken. DirectX 10 and 11 provide so much of their capabilities as earlier cards can handle ("10 level 9" capability). But DirectX 11 does not provide support for applications written to require DirectX 9.0c and earlier.

You need to install the DirectX 9.0c runtime if you want to run games that require DirectX 9.0c or earlier. It does not interfere with any part of DirectX 11.
Post edited April 05, 2013 by cjrgreen
avatar
Generalelectric: I was forced to install this. The first time I tried not installing that and got some message about a missing file whenever I tried to run this game. So I reran the installer and let is install 9.0c and the game worked.

Does this overwrite my DirectX 11, or whatever it is now, files?
No it doesn't, DirectX 10 and 11 are updated through Windows Update IIRC and don't interfere with older DirectX versions. DirectX 9 setup OTOH updates you to the latest version 9 and older versions because 9 is backwards compatible with older versions
I reinstalled this game recently after reinstalling my OS.

For some reason I didn't get a prompt for dx 9c. I went away for a while and came back and it was installed. I wonder why.