It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Is there a solution? It's a problem specific to Longest Journey on Nvidia cards with latest drivers - anti aliasing works, but pieces of the scene vanish and appear when you move. The game looks quite bad without AA, any assistance appreciated.
Post edited February 23, 2014 by Kamamura
I don't know jack when it comes to graphics card settings and whatnot, but I can only offer up what I have found to work for me.

My settings are pretty simple. The egg in the prologue used to disappear on me, so when I first encountered that problem, I went to work to see if I could fix it. Took a bit of messing around at first but what I have it on now has worked for me. I just did a test run with the latest driver for my GPU installed (GeForce 334.89), and went back to this "problem area" of the game. Everything okay, so I will I assume everything is still okay with the rest of game. My settings in the Nvidia control panel for the game is antialiasing -FXAA: on, antialiasing -mode: Application-controlled (which to be honest, i don't know if this setting is even necessary).
avatar
1322: My settings in the Nvidia control panel for the game is antialiasing -FXAA: on, antialiasing -mode: Application-controlled (which to be honest, i don't know if this setting is even necessary).
Yes, I tried that, it removes the problems with vanishing parts of the scenes, but unfortunately, it also switches anti aliasing off completely (you may notice it on edges). "Application controlled" means that the software will decide, and since TLJ does not support AA, it's off, and FXAA is also off, because the drivers don't enable it when the game does not states it's supported. I managed to turn it on once by fiddling with a special launcher, and it smoothes the edges somewhat, but all text is turned into blurry smudge, it's not playable at all.

So thank you, but this is not a solution.
avatar
Kamamura: snip
In theory, you are correct that setting the mode to app-control (which is a global setting) would turn everything off, but it didn't, at least not on my end. Maybe I have a screwy machine. Ticking the Enable 3D acceleration in the launcher seems to tell the program something. Ticking it off, nothing works no matter what I do with my Nividia settings. Everything goes blocky, especially the text.

What are your current settings?

I now have the mode set on Enhance app setting, AA setting at 2x. Override gave me the problem.

My experience in the past is that going too heavy in the settings would crash the game a lot, particularly after cut scenes.

I don't know how long you've had the game, and if everything was working fine up until now with the latest drivers, but I am also interested if finding something that would make the game look better (minus a complete overhaul). But I think due the games age and design (and our hardware) we are going to be limited how far it could be pushed.
Post edited February 24, 2014 by 1322
Screenshot or it did not happen ;-)

Seriously, I think that you are a victim of a placebo effect, and that both "Enhance" and "Application control" result in Anti Aliasing being off, I tried and it's so for me. Once you select "Override", then yes, AA is now really turned on, but the geometry problems start to occur. I thought that the problem is with MSAA, because it performs AA selectively only on polygon edges, so I used Nvidia Inspector to enable SSAA (supersampling), and it looks super nice, but once again, the objects start to pop in and out.

I wrote here because I thought that maybe someone found a way, but there is probably none, the game is old and probably does something in a non-standard way. Many old games work with MSAA forced via drivers with few problems.

If you disable 3D acceleration, it's understandable that NVidia settings do not matter anymore, since the program stops using D3D API and HW accelerated functions, and everything is drawn in a software mode by the CPU. This looks of course super ugly, because lighting and shadow effects disappear, as well as texture filters.
Post edited February 25, 2014 by Kamamura
avatar
Kamamura: Screenshot or it did not happen ;-)
What good would that do? If you feel that I am bullshitting you then that is your problem.
avatar
Kamamura: Seriously, I think that you are a victim of a placebo effect, and that both "Enhance" and "Application control" result in Anti Aliasing being off
Not a placebo effect. Possibly I have something else going on that I'm not aware of? Maybe, but I know what I see. Anyway, sorry I couldn't be of any help. Thanks for your insight and good luck.
Post edited February 25, 2014 by 1322
avatar
Kamamura: Screenshot or it did not happen ;-)
avatar
1322: What good would that do? If you feel that I am bullshitting you then that is your problem.
avatar
Kamamura: Seriously, I think that you are a victim of a placebo effect, and that both "Enhance" and "Application control" result in Anti Aliasing being off
avatar
1322: Not a placebo effect. Possibly I have something else going on that I'm not aware of? Maybe, but I know what I see. Anyway, sorry I couldn't be of any help. Thanks for your insight and good luck.
All sources I found state that your method does not work. I tried it and it does not work. If you did somehow manage it, it would be a significant success.
avatar
1322: What good would that do? If you feel that I am bullshitting you then that is your problem.

Not a placebo effect. Possibly I have something else going on that I'm not aware of? Maybe, but I know what I see. Anyway, sorry I couldn't be of any help. Thanks for your insight and good luck.
avatar
Kamamura: All sources I found state that your method does not work. I tried it and it does not work. If you did somehow manage it, it would be a significant success.
I just performed a full uninstall on the game (using Revo Uninstaller to delete everything, including registry entries), did a clean reinstall, and I get the same results I've reported earlier. What can I say? Doubt that it means anything, but I'm using a GeForce GTX 670 with 334.89 drivers.
You are not the first to try getting anti-aliasing to work. The problem is the way Longest Journey renders the 3D on top of the 2D which seems to be done by boxes surrounding the characters. AA applied to these elements results in these geometry problems and so far no one has found a solution.

You'd need to find a way to apply the post processing to the complete image. Basically you'd have to run the game in an emulator and after that use an FXAA shader. A way to do this would be to get Windows98 running in Dosbox (it's possible, but not easily) and then use ykhwong's build of Dosbox to apply the shader via the Direct3D renderer.

If you found another way - please share :)
avatar
sid6581: You are not the first to try getting anti-aliasing to work. The problem is the way Longest Journey renders the 3D on top of the 2D which seems to be done by boxes surrounding the characters. AA applied to these elements results in these geometry problems and so far no one has found a solution.

You'd need to find a way to apply the post processing to the complete image. Basically you'd have to run the game in an emulator and after that use an FXAA shader. A way to do this would be to get Windows98 running in Dosbox (it's possible, but not easily) and then use ykhwong's build of Dosbox to apply the shader via the Direct3D renderer.

If you found another way - please share :)
Both nVidia's FXAA & AMD's Morphological filtering use post-processing filters to apply a slight blur to every single pixel onscreen in a D3d application when they are selected in the respective driver control panels. The effects work well in some games that cannot be AA'ed by traditional means, or older games just like this one. Unfortunately, this effect in this game blurs the text so much that it is barely legible.

However, in this game FXAA or Morphological filtering will work fairly well if you de-select "3d accelerator" at the beginning of the game when the options panel is presented. Morphological filtering (what I have) and FXAA will work fine on a game rendering in D3d software mode--which is what happens here when "3d accelerator" is de-selected and why it works. (Many people forget that D3d has a software mode, probably because it isn't used much these days.) The effect leaves something to be desired, still, but I think it's much better than turning on 3d acceleration and trying the FSAA the game because of the buffer/frame jumbling that occurs. It's easy to see the difference, at least with AMD's Morphological filtering, between D3d software mode with and without MF turned on. (I can't speak to how well nVIdia's drivers FXAA D3d software mode because I don't have a nVidia card.) I would be surprised to learn it doesn't work for nVidia owners, though.

Morphological filtering works fine for D3d software mode whether W-buffer or Force single buffer settings are on or off--makes no apparent difference that I can see. Text is still slightly blurry, but it's definitely legible--unlike when 3d acceleration is turned on in game and Morphological filtering is selected--wherein text becomes fairly illegible along with other undesirable graphics artifacts.

Best for me:

1) 3d acceleration turned off (which runs the game's D3d software mode)

2) Morphological filtering ON (FXAA for nVidia) in the the driver control panel

3) All other FSAA driver control panel effects turned off

4) If I set Game.exe to "Windows Service Pack 2" compatibility mode or I leave it unchecked so that it runs in the normal Win8.1x64 mode (no compatibility mode selected) the game runs and looks exactly the same for me

5) I set "disable high dpi" compatibility mode

6) I set "run as Admin" compatibility mode

The only real penalty to the D3d software mode is the shadow she casts is pixellated. But, compared to the jaggy-fest she is in D3d software mode without Morphological post-processing filtering selected, or in D3d hardware mode with FSAA & Morphological turned off--the grainy shadows are easy to put up with...;) It's a trade off, but it's an old game.
avatar
waltc: snip
Yes. This is basically how my game is set up. It isn't a true AA, but better than nothing. The only real difference is 1 where turning off 3D acceleration for me turns off the effect.
avatar
waltc: snip
avatar
1322: Yes. This is basically how my game is set up. It isn't a true AA, but better than nothing. The only real difference is 1 where turning off 3D acceleration for me turns off the effect.
That's interesting--thanks for the reply!

Edit: Meant to add that it is interesting that nVidia's drivers apparently don't use D3d software mode, but must simply revert to 2d-only (GDI mode) operation when a game doesn't call 3d acceleration. In the Catalysts, the Morphological filtering option plainly says it only works in D3d mode, so I know the Catalysts are running the game in D3d software mode when I turn off the game's 3d acceleration because Morphological filtering works in the game regardless of whether 3d acceleration is enabled in-game.

I hadn't thought about the ramifications of this--because it could mean that nVidia's drivers also won't support the use of the direct3d DOSBOX output mode, which I currently combine with shaders to run *all* of my DOSBOX games, usually with the HQ2x.fx shader applied (available in the DOSBOX "svn-daum" version--which is the only DOSBOX version I use currently.)

Or, it could just mean that nVidia has deliberately setup FXAA so that it won't run in D3d software mode...! This is valuable info--appreciate your sharing it.
Post edited April 05, 2014 by waltc
avatar
Kamamura: Is there a solution? It's a problem specific to Longest Journey on Nvidia cards with latest drivers - anti aliasing works, but pieces of the scene vanish and appear when you move. The game looks quite bad without AA, any assistance appreciated.
I had the same issue and managed to solve it. See step by step instructions here:

http://www.gog.com/forum/the_longest_journey_dreamfall/anti_aliasing/post48