It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I finally found a way to make anti-aliasing work on Windows 8!
It was a painful process, since I was getting the flickering every time I tried to turn AA on.
My configuration:

Radeon HD 7640G, AMD Quad-Core A8-4500M, Windows 8 64-bit

In Config.exe, unchecked everything

Here are the settings that I used in ATI Catalyst:

AMD Catalyst 13.4

AA samples 24xEQ (Filter: Edge-Detect)
Anti-Aliasing Method Supersampling
Anisotropic Filtering at 16x (Texture Filtering: High Quality)
Tessellation to AMD Optimized
Maximum Tessellation Level to AMD Optimized
Vertical Refresh to off unless application specifies
OpenGL Triple Buffering Off

As for the preferences.ini :

[DirectX]
bool_IsDoubleBuffer=1
int_BitDepth=32
bool_ShadowsOn=1
bool_UseHardware=1
bool_StartFullscreen=0

When I was running the game with bool_IsDoubleBuffer=0 and bool_UseHardware=0, the game looked awful, no 3D acceleration, ATI catalyst settings didn't work, just pixelated software mode quality. However, if I ran the game with both features ON in full screen mode, AA would work, but I would also get the flickering. The solution was to run TLJ with both double buffer and hardware acceleration on in a windowed mode.
The next step was to artificially turn the window into full screen. I checked "Run in 640 x 480 screen resolution" in the preferences and also in the shortcut preferences chose the "Run: Maximized" option, which allowed me to run the game in a maximized window. The last step was to get rid of the window title bar and the borders for the complete full screen feel. For that purpose, I downloaded Maximized Window 1.

Now, every time I load the game, I start Maximized Window 1 before I start the game, load TLJ, use ALT+TAB to switch to Maximized Window 1 in order to get rid of the window borders, and, voilà!, full screen mode with AA, Anisotropic Filtering and NO FLICKERING!

I know this sounds prehistoric, but this is the only way I could make it work on my system.

I hope it helps you as well!
Post edited July 27, 2013 by 301gene
avatar
Longcat: ... all I had to do to fix this was to use configure.exe in the game directory to set 'Force 16bit resolution' to true. Maybe try to fiddle around with this if you can't get it to work. It also let's you toggle 'Force single buffer'....
it worked for me too!! In my case it was enough check "force single buffer"
I managed to find a way to enable anti-aliasing in "full-screen" and without flickering. This is with the Steam version of the game, but should be doable with the GOG version too.

To get this game to look nice you really need to enable anti-aliasing. The problem is that doing so usually results in flickering issues that can only be overcome in windowed mode, but this mode normally comes with an ugly title bar and borders. The following steps allowed me to get the game to work with full Anti-Aliasing, without any flickering and without any borders, just like full-screen mode. My card is an AMD HD 7850 and I'm using AMD Catalyst version 13.4.

The first step is to create a batch file that switches to the game's native 640x480 resolution, launches the game in a window, remove the title bar and moves the window a few pixels so there are no visible borders. Once you quit the game, the batch file sets the monitor to high resolution again (you'll need to define the exact values that match your monitor).

Download NirCmd from nirsoft.net

Extract it to a folder on your desktop

Create a batch file TLJ.cmd in the same folder. If Windows doesn't show file extensions, now is the time to enable it, otherwise you're likely to end up with some other extension (e.g. TLJ.cmd.txt).

Edit the file in Notepad and copy the following commands (without the hyphens) to it:

-------------------------------------------------------
nircmd.exe setdisplay 640 480 32
call steam.exe -applaunch 6310
nircmd.exe wait 1000
nircmd.exe win -style process game.exe 0x00C00000
nircmd.exe win move process game.exe -2 -2
nircmd.exe waitprocess game.exe setdisplay 1680 1050 32
-------------------------------------------------------

Note that if your game is not installed via Steam you'll probably need to replace the line "call steam.exe -applaunch 6310" with something like "call ......\The Longest Journey\game.exe" (where ...... represents the full path to where the game is installed". I haven't tested it though, as I purchased the game from Steam.

Also, change the resolution values (1680 1050) in the last line to the values you normally use (e.g 1920 1080)

In Catalyst Control Center configure Anti-Aliasing as follows:

Under Gaming, click 3D Application Settings then click "Add..."
Browse the folder where the game is installed (e.g. C:\SteamLibrary\SteamApps\common\The Longest Journey\game.exe)
Define the settings as below:

-------------------------------------------------------
Anti-Aliasing Mode: Override
Anti-Aliasing Samples: 8x
Filter: Standard
Anti-Aliasing Method: Multisampling
Morphological Filtering: Off
Anisotropic Filtering Mode: Override
Anisotropic Filtering Level: 16x
Texture Filtering Level: High Quality
Syrface Format Optimizations: Off
Wait for Vertical Refresh: Off, unless app specifies
OpenGL Triple Buffering: Off
Tessellation Mode: Use app settings
Maximum Tessellation Level: Use app settings
-------------------------------------------------------

Edit the game preferences.ini file in Notepad and change its content so that the lines under the [DirectX] section are the same as the ones below. Alternatively, just overwrite the entire content with what's below, if you don't care about the other settings.

-------------------------------------------------------
[Preferences]
AudioDevice=autodetect
SfxVolume=1.000000
VoiceVolume=1.000000
MusicVolume=1.000000
bool_Subtitles=1
bool_AprilHighRes=1
bool_ShadowsOn=1
bool_AllowFastForward=0
[DirectX]
int_BitDepth=32
bool_ShadowsOn=1
bool_IsDoubleBuffer=1
bool_ForceSingleBuffer=0
bool_StartFullscreen=0
-------------------------------------------------------

This file is normally located in C:\Users\YourUserName\AppData\Roaming\The Longest Journey\
If you can't find the file, create it in this folder. Here too you'll need file extensions to be displayed to ensure that the file is created with the correct name.

Once done, just double click the TLJ.cmd batch file to launch the game :-)

Good luck!
I did some research concerning AA support for TLJ. Turns out that it is possible to enable AA if you have Radeon, but it is not possible when you have GeForce. That is a sad state of affairs. I was hoping that with the reignited hype around TLJ related to Dreamfall Chapters someone (preferably Funcom or Red Thread Games) would take a look at TLJ code and tried to make it more compatible with antialiasing- but this does not seem to be the case. Pity.