It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Hi guys!

Game installs fine, Intro plays, Menus work and i can configure graphic mode and everything without any issue (it even detects the native 1366x768 16:9 resolution of this notebook). Then, i click new game, and the movie plays; Pressing escape to skip it.

Then i get a "box" of about 10x10 pixels in the upper left corner of the screen, and the rest is black. The colors change in the little box if i move the mouse. If i press ESC, the Menus show normal. If i move in the game, i can hear the audio starting the speech about how to train and so on, so basically the game works, but ... well, i can't see anything :)

Anyone a clue what could be the issue? I'am trying to run this on an i7-2670QM CPU utilizing a GF540M with dedicated memory.

Kind regards,
Gilthanaz
This question / problem has been solved by voodoo47image
see the sticky and the intel fix.
Awww well!

While i wrote the post above and thought i proabably should append a dxdiag output, i noticed that this notebook actually runs a Intel HD Graphics Card, and only switches if the application appears to need more GPU power. Of course it did NOT recognize System Shock as a GFX heavy application...

Solution:
Right Click somewhere on your Desktop; Open NVIDIA Control Panel. There, navigate to "3D Settings", sub branch "Manage 3D Settings". On the right side, switch to the Tab "Program Settings".

Press the "Add" Button, then:
1. Select Program: Here, find your start.exe in the directory where you installed System Shock 2.
2. Select the preferred graphics processor for this program: Set it to the NVIDIA Card
3. Save the Settings. Start System Shock 2 with the start.exe (The default link created by the installer is ok, it points to start.exe).

Voila!

Hope i could not only help myself, but someone else with the same issue as well :)

Kind Regards,
Gilthanaz

@voodoo47: Hehe, we crossposted; Thanks for the hint, i also read that now - i prefer my solution, as it does not require any 3rd party tools as long as you have a second GPU in the notebook :) I appreciate that you took the time to hit me over the head with the fact that i did not read the sticky :)
Post edited February 14, 2013 by Gilthanaz
I'd just like to add that I was only able to get the game to work with Optimus by selecting shock2(.)exe in step 1 of the instructions, not start(.)exe.

PS I had to put () around the periods because the forum thinks they're links to websites and won't let me post them
Post edited February 28, 2013 by ScruffyTJanitor