It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
I bought the game as soon as it was for sale and was dying to try it out, but I can never get past the starting screen, as all I ever get to see is a black screen. I can still hear the menu 'theme' on the background and (usually) sound effects when I move my cursor over what are probably the menu buttons, but I cannot see anything.

It happens regardless of whether I download or install anything such as the ss2tool. I uninstalled the game and re-installed it, but this time enabling the intel safe mode fix on ss2tool's install screen, but it didn't help. I tried doing it manually as well, still didn't work.

The only way to close the program is to ctrl+alt+del and force it to close, after which it stops responding and crashes. I've not been able to find a way to fix this. What do I do now?



I have an older PC:
Windows 7 32-bit
Intel Core i3 540 @ 3.07 GHz
4GB Ram
Geforce 9800GT 1GB (drivers fully up-to-date)
This question / problem has been solved by voodoo47image
try running it in a window (see the sticky). make sure you are not forcing any anti aliasing mode via your geforce control panel.
Huh, It appears to work perfectly when running it in windowed mode. I'll check out the control panel.
EDIT: Forced AA doesn't seem to be the case.
Post edited February 15, 2013 by LightningBlade7
try changing your video device as described here, and re-enable fullscreen.
Post edited February 15, 2013 by voodoo47
I don't have any other options when I check out the "choose hardware options" section.
Post edited February 15, 2013 by LightningBlade7
try uncommenting (deleting the ; character) from vsync_mode 0 in the cam_ext.cfg:
; display refresh synchronization mode (in "single_display_mode"), default is 3 which means enabled
; in-game and in menu screens. To disable synch, set mode 0.
; NOTE: certain graphics driver settings may override synch behavior of the game
; NOTE2: synch support in windowed mode with "use_d3d_display", may depend on Windows version and settings
vsync_mode 0
Done, but it didn't work either. Still getting a black screen =(
try setting the framerate cap to something lower, 65 or so.
In cam_ext, right? lowered it to 65, didn't help. I'm getting the feeling that I'm going to have to play this in windowed-mode.
Thank you very much for all the effort you put into finding possible solutions though.
yeah. more things to try - edit cam_cfg (the one found directly in the System Shock2 folder), modify multisampletype like this

;multisampletype 8
and uncomment (remove ; on the start of the line) d3d_disp_no_rgb10_buf, like this

d3d_disp_no_rgb10_buf
also make sure you are running in the same resolution as your desktop.
Post edited February 20, 2013 by voodoo47
avatar
voodoo47: and add
d3d_disp_no_rgb10_buf
Where do I need to add that
Post edited February 15, 2013 by LightningBlade7
cam_ext.cfg, as always.
That did it! Amazing! I'm not entirely sure how or why or even what it does, but it worked!
Thank you very, very, VERY much! You've been unbelievably helpful!
Post edited February 15, 2013 by LightningBlade7
the non-technical explanation would be - it's a thingy that makes sky gradients smoother. both ati and nvidia like to break support for it in their drivers every once in a while.
Post edited February 15, 2013 by voodoo47
avatar
LightningBlade7: That did it! Amazing! I'm not entirely sure how or why or even what it does, but it worked!
Thank you very, very, VERY much! You've been unbelievably helpful!
Are you running the game on a laptop or something with an integrated GPU?
I'm running Win7 and found that you can right-click the icon and a "Run with Graphics Processor" option comes up. I just chose my main GPU from there and it fixed the problem immediately.