It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Just started playing. I am noticing that the audio (dialogue) is skipping every 3-4 seconds, and the gameplay is stuttering too. Any thoughts? I doubt my PC is unable to play a 14 year old game.

Thanks.
No posts in this topic were marked as the solution yet. If you can help, add your reply
that depends. post your shock2.log
avatar
voodoo47: that depends. post your
: CPU: arch=x86-64 , fam=586 , cpus=8
: SIMD: SSE=3 , 3DNow=0
: OS Version: 6.1.7601 Service Pack 1
: Desktop resolution: 1600 x 900
: Virtual desktop resolution: 1600 x 900
: -----------------------------------------------------------
: CWD: C:\GOG Games\System Shock 2
: -----------------------------------------------------------
: App Version: System Shock 2 Patch Final 2.4
: --------------------- misc config -------------------------
: resname_base .\+.\DataPermanentMods\res+.\Data+.\Data\res
: cd_path .
: load_path .+.\DataPermanentMods+.\Data
: script_module_path .+.\DataPermanentMods+.\Data
: movie_path .\cutscenes+.\DataPermanentMods\cutscenes+.\Data\cutscenes
: mod_path DataPermanentMods+patch_ext
: install_path .+.\DataPermanentMods+.\Data
: game_screen_size 640 480
: game_screen_depth 32
: game_screen_flags 45
: game_full_screen 1
: screen_size 640,480
: screen_depth 16
: game_hardware 1
: single_display_mode 2
: ui_scale_mode 2
: use_d3d_display
: framerate_cap 100.0
: SlowFrame 4
: SlowFrameUI 10
: force_32bit
: force_32bit_textures
: mipmap_mode 2
: lm_mipmap_mode 0
: lm_init_texmem 2
: lm_filter_margin 1
: disable_lightmap_aniso
: tex_edge_padding 2
: alpha_test_as_opaque
: multisampletype 8
: d3d_disp_enable_distortionfx
: sfx_device 4
: sfx_channels 48
: sfx_vol_music -474
: sfx_vol_2d 0
: sfx_vol_3d 0
: sfx_mixer_timeout 200
: game shock
: obj_min -6144
: obj_max 2560
: max_refs 10240
: gui_font fonts\mainfont
: skip_intro
: crop_movies
: new_mantle
: z_far 512
: render_weapon_particles
: legacy_force_match_unrefs 0
: shock_single_bind_set
: shock_quicksave_slot 14
: edit_screen_depth 16
: -----------------------------------------------------------
: Enumerating D3D9 adapters (1)...
: Adapter 0
: device name: \\.\DISPLAY1
: driver :
: descr : ATI Mobility Radeon HD 4670
: driver ver : 0x0008000E-000A02CC
: vendor id : 0x00001002
: device id : 0x00009488
: subsys id : 0x02FE1028
: device guid: D7B71EE2-D7C8-11CF-5471-F422A1C2
: Modes
: 640 x 480 x 16
: 720 x 480 x 16
: 800 x 600 x 16
: 1024 x 768 x 16
: 1280 x 720 x 16
: 1600 x 900 x 16
: 640 x 480 x 32
: 720 x 480 x 32
: 800 x 600 x 32
: 1024 x 768 x 32
: 1280 x 720 x 32
: 1600 x 900 x 32
: Device Validation
: validated ok, device added (0, E390000)
: Enumeration done
: OpenAL Init...
: : 6.14.357.24
: : 2.2.0.5
: Default device: Generic Software
: Enumerating devices without validation...
: Device: Generic Software
: found 1 unvalidated device(s)
: Opening default OpenAL device "Generic Software"...
: Device 0 (default)
: name : Generic Software
: version : 1.1
: version str: 1.1
: vendor : Creative Labs Inc.
: renderer : Software
: 3D sources : 248
: 2D sources : 8
: EFX : 1
: EAX2 : 1
: EAX3 : 0
: EAX4 : 0
: EAX5 : 0
: occlusion : 1
: XRAM : 0
: Opened device 'Generic Software'
: EAX reverb support enabled
: occlusion support enabled
: D3DProvider: Enumerating adapter 0 modes
: 640 x 480 x 16
: 720 x 480 x 16
: 800 x 600 x 16
: 1024 x 768 x 16
: 1280 x 720 x 16
: 1600 x 900 x 16
: 640 x 480 x 32
: 720 x 480 x 32
: 800 x 600 x 32
: 1024 x 768 x 32
: 1280 x 720 x 32
: 1600 x 900 x 32
: D3DProvider: Enumeration done
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 640x480x32 ; mode 640x480x32 (5 9 0 2D)
: CreateDevice: res = D3D_OK ; 640x480 fmt=35 zfmt=75 cnt=1 ms=8 swap=1 fs=1 hz=0 pres=1 flags=2
: OpenAL Init...
: : 6.14.357.24
: : 2.2.0.5
: Default device: Generic Software
: Enumerating devices without validation...
: Device: Generic Software
: found 1 unvalidated device(s)
: Opening default OpenAL device "Generic Software"...
: Device 0 (default)
: name : Generic Software
: version : 1.1
: version str: 1.1
: vendor : Creative Labs Inc.
: renderer : Software
: 3D sources : 248
: 2D sources : 8
: EFX : 1
: EAX2 : 1
: EAX3 : 0
: EAX4 : 0
: EAX5 : 0
: occlusion : 1
: XRAM : 0
: Opened device 'Generic Software'
: EAX reverb support enabled
: occlusion support enabled
: OpenAL Init...
: : 6.14.357.24
: : 2.2.0.5
: Default device: Generic Software
: Enumerating devices without validation...
: Device: Generic Software
: found 1 unvalidated device(s)
: Opening default OpenAL device "Generic Software"...
: Device 0 (default)
: name : Generic Software
: version : 1.1
: version str: 1.1
: vendor : Creative Labs Inc.
: renderer : Software
: 3D sources : 248
: 2D sources : 8
: EFX : 1
: EAX2 : 1
: EAX3 : 0
: EAX4 : 0
: EAX5 : 0
: occlusion : 1
: XRAM : 0
: Opened device 'Generic Software'
: EAX reverb support enabled
: occlusion support enabled
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 640x480x32 (5 9 0 2D)
: CreateDevice: res = D3D_OK ; 1600x900 fmt=35 zfmt=75 cnt=1 ms=8 swap=1 fs=1 hz=0 pres=1 flags=2
: OpenAL Init...
: : 6.14.357.24
: : 2.2.0.5
: Default device: Generic Software
: Enumerating devices without validation...
: Device: Generic Software
: found 1 unvalidated device(s)
: Opening default OpenAL device "Generic Software"...
: Device 0 (default)
: name : Generic Software
: version : 1.1
: version str: 1.1
: vendor : Creative Labs Inc.
: renderer : Software
: 3D sources : 248
: 2D sources : 8
: EFX : 1
: EAX2 : 1
: EAX3 : 0
: EAX4 : 0
: EAX5 : 0
: occlusion : 1
: XRAM : 0
: Opened device 'Generic Software'
: EAX reverb support enabled
: occlusion support enabled
: OpenAL Init...
: : 6.14.357.24
: : 2.2.0.5
: Default device: Generic Software
: Enumerating devices without validation...
: Device: Generic Software
: found 1 unvalidated device(s)
: Opening default OpenAL device "Generic Software"...
: Device 0 (default)
: name : Generic Software
: version : 1.1
: version str: 1.1
: vendor : Creative Labs Inc.
: renderer : Software
: 3D sources : 248
: 2D sources : 8
: EFX : 1
: EAX2 : 1
: EAX3 : 0
: EAX4 : 0
: EAX5 : 0
: occlusion : 1
: XRAM : 0
: Opened device 'Generic Software'
: EAX reverb support enabled
: occlusion support enabled
: Loaded script module "allobjs"
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 1600x900x32 (7 9 1 3D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 640x480x32 (5 9 1 2D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 1600x900x32 (7 9 1 3D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 640x480x32 (5 9 1 2D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 1600x900x32 (7 9 1 3D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 640x480x32 (5 9 1 2D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 1600x900x32 (7 9 1 3D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 640x480x32 (5 9 1 2D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 1600x900x32 (7 9 1 3D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1600x900x32 ; mode 640x480x32 (5 9 1 2D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 640x480x32 (5 9 0 2D)
: CreateDevice: res = D3D_OK ; 1280x720 fmt=35 zfmt=75 cnt=1 ms=8 swap=1 fs=1 hz=0 pres=1 flags=2
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 1280x720x32 (7 9 1 3D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 640x480x32 (5 9 1 2D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 1280x720x32 (7 9 1 3D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 640x480x32 (5 9 1 2D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 1280x720x32 (7 9 1 3D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 640x480x32 (5 9 1 2D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 1280x720x32 (7 9 1 3D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 640x480x32 (5 9 1 2D)
: sw framerate cap requested (10000 us)
: D3DProvider StartMode: smode 1280x720x32 ; mode 1280x720x32 (7 9 1 3D)
Are you running this on Win XP, Vista or 7 and what audio hardware do you have? I have that problem regularly with many games on my Win 7 machine with a Realtek sound solution. According to a Google search, it's been a problem with Windows in general since Vista. It doesn't appear to have reliable fix, though in my case, a simple reboot will sometimes make it go away.

EDIT - I type too slow...
Post edited February 14, 2013 by cogadh
check whether you have

d3d_disp_limit_gpu_frames 1 1

in your cam_ext.cfg. also try enabling/disabling openal.
Post edited February 14, 2013 by voodoo47
avatar
voodoo47: check whether you have

d3d_disp_limit_gpu_frames 1 1

in your . also try enabling/disabling openal.
I am running Windows 7 but this hasn't happened with any other game. I am unable to change openal settings in the game (the option is grayed-out). Not sure how to open cam_ext file, - I am not very computer savvy. Well, I'll reboot now and see what happens.
Post edited February 14, 2013 by DRF1983
try disabling multisampling, and maybe set the framerate_cap (in cam_ext.cfg) to lets say, 65.
avatar
voodoo47: try [url= multisampling[/url], and maybe set the framerate_cap (in ) to lets say, 65.
Thanks. Working now after a reinstall. Bad first installation?
Still some static-y audio on my end. Wasn't an issue on my disc copy (as far as I can remember.)

I am on Windows 8 64bit with a Creative XFI Fatalty card using the Creative PAX custom drivers. I also use the Shark007 codec pack. I've done everything in the thread, but the sound is still choppy.
try disabling audio acceleration in the sound menu.
avatar
voodoo47: try disabling audio acceleration in the sound menu.
That did it. Down with OpenAL!
avatar
voodoo47: try disabling audio acceleration in the sound menu.
avatar
Vagabond: That did it. Down with OpenAL!
Well, it adds EAX support which is very nice to have in a game like Shock 2.