It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
After installing the unofficial patch, I'm still unable to Alt-Tab. While the installation is straight forward, is there any way to validate it was implemented?

avatar
Petek: I think I figured out how to solve the Alt-Tab problem. I wasn't working with the GOG installation of SMACX. When I used the new GOG version, Alt-Tab stopped working for me. It now seems to me that GOG modified the exe files and (deliberately or not) disabled Alt-Tabbing.

The solution is simple: Download and install scient's unofficial patch. His patch consists entirely of the two exe files (terran.exe and terranx.exe). When I copied the unofficial patch to the new GOG folder and ran it, Alt-Tab came back to normal.

I've used the unofficial patch for several years. It doesn't cause any problems, but fixes many bugs. You can download it, for example, from

http://www.weplayciv.com/forums/downloads.php?do=file&id=240

WePlayCiv is a reputable site, so the files should be free of malware. I'd be interested to hear if this solution works for you, Thanks.
I have already tried disabling the opening movie, instaling the unofficial patch, and setting "ForceOldVoxelAlgorithm" to zero.

I run on the 1920x1080 resolution. And the funny thing is that there I was able to alt-tab in my older GoG copy of the game (no SMAX).
Post edited December 21, 2012 by justinlee999
avatar
Negatus: After installing the unofficial patch, I'm still unable to Alt-Tab. While the installation is straight forward, is there any way to validate it was implemented?
Make sure that you copied the unofficial patch exes to the proper folder (C:\GOG Games\Sid Meier's Alpha Centauri). I'd also recommend launching the game directly by double-clicking on the exe file (instead of using the shortcut created by GOG on your desktop), just to make sure that you're launching the correct version. You also can look at the link to the patch and see whether or not you are still affected by some of the bugs that were fixed.

If you've verified that you're using the unofficial patch and Alt-Tabbing still doesn't work, I don't know what to suggest. You might try using some of the compatibility mode options. Some of these options affect video/graphics.
avatar
justinlee999: I have already tried disabling the opening movie, instaling the unofficial patch, and setting "ForceOldVoxelAlgorithm" to zero.

I run on the 1920x1080 resolution. And the funny thing is that there I was able to alt-tab in my older GoG copy of the game (no SMAX).
Disabling the opening movie (or not) seems to have no effect, at least for me, in GOG's version. See my advice to Negatus to make sure that you're using the unofficial patch.
Post edited December 21, 2012 by Petek
avatar
justinlee999: Well, I overwrote the original terran and terranx executables with the ones in the patch, and I even opened them directly. Alt-tab still does not work.
Try Alt-Ctrl-Tab. For me, that brings up a menu of running apps that you can then switch to.
My post can't get through. Only this.
http://pastebin.com/S3ctp8eJ
Post edited December 22, 2012 by justinlee999
Thank you, disabling the intro movie fixed alt + tab function for me.
avatar
Petek: To enable alt-tabbing, try changing the Alpha Centauri.ini line

DisableOpeningMovie=0

to

DisableOpeningMovie=1