It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Sadly, no luck for me with any of the tips in this thread :(
I downloaded the patch and used it and all of the movies work audio only except for the monolith movie which works flawlessly. This is the CD version of the game with the 1.04 patch applied.
Ok i got it to work too, but why my mouse moves in slow motion and the whole screen too...
Couldn't transcode the movies using the installer, so I did it myself using ffmpeg. However, when the movies play back in the game they play back at something like 2 or 3 fps (not in slow motion, but it skips a lot of frames). Are there any settings I should be aware of to get this to work? I tried the x264 codec and raw uncompressed video, with the same result. The videos play back just fine in media player classic.

Edit: I got the transcoding in the installer to work, and get the same result. For some reason the video playback using the unofficial ddraw.dll seems to be extremely slow.

Edit2: Aha! The game was automatically using the LAV filters, but couldn't cope with the output color space it was being given. Limiting the output color space to RGB24 fixed the problem!
Post edited October 04, 2013 by VerGreeneyes
I tried applying this unofficial patch to the Steam version just to see if it worked. The patch seems to install without issues, but Septerra Core crashes on launch. I use Win7 64.

Have you heard how other Steam owners have faired with this?

edit: The Steam version has no DRM and runs perfectly without Steam.

Ah, the Steam version is 1.02. I upgraded to 1.04 and now the patch works... mostly. The movie video streams are blank white, but the audio is working. I tried playing them with external players [VLC, Zoom, Quicktime] and got the same result. Perfect audio; no video.

I'll try deleting the new video files, updating Quicktime, and running your patch update again.
Post edited October 07, 2013 by lightswitch
avatar
VerGreeneyes: Edit2: Aha! The game was automatically using the LAV filters, but couldn't cope with the output color space it was being given. Limiting the output color space to RGB24 fixed the problem!
How did you manage this? What tool did you use? Even erightsoft's Super, supposedly the most feature rich freeware video converter doesn't have an option to convert from yuv to rgb24, nor anything mentioning color space at all.
avatar
lightswitch: How did you manage this? What tool did you use? Even erightsoft's Super, supposedly the most feature rich freeware video converter doesn't have an option to convert from yuv to rgb24, nor anything mentioning color space at all.
I actually converted the videos to some YUV444 format I think, which seemed to match the quicktime originals. The tool I used was ffmpeg. However, the LAV video decoder (which the game automatically chose as its default decoder with the unofficial patch in place) allows you to select which output color spaces are allowed - so I set it to only allow RGB24. You should be able to do the same with with ffdshow if you prefer that. Most other spaces just show up as black, and RGB32 gets really choppy for some reason.

If you want my converted videos, by the way, just ask and I'll PM you a link (I'm not sure how GoG would feel about me uploading content from the game here, converted or not).
Post edited October 07, 2013 by VerGreeneyes
avatar
lightswitch: How did you manage this? What tool did you use? Even erightsoft's Super, supposedly the most feature rich freeware video converter doesn't have an option to convert from yuv to rgb24, nor anything mentioning color space at all.
avatar
VerGreeneyes: I actually converted the videos to some YUV444 format I think, which seemed to match the quicktime originals. The tool I used was ffmpeg. However, the LAV video decoder (which the game automatically chose as its default decoder with the unofficial patch in place) allows you to select which output color spaces are allowed - so I set it to only allow RGB24. You should be able to do the same with with ffdshow if you prefer that. Most other spaces just show up as black, and RGB32 gets really choppy for some reason.
My converted files are YUV as well, but no changes I made in the LAV Video Configuration had any effect on the FMVs inside Septerra. How can I tell which decoder is being chosen by the patched game?
If you have the system tray icons turned on for the various parts of the LAV filters, you can see them when you alt-tab out. You should be able make the LAV video decoder the default by going to the Formats tab in its settings and checking the various codecs.
Ok guys, I have finnaly got it fully working on Windows 8 with Steam version.
I've updated the game with the unnofficial patch from this site. The video conversion went wrong so I converted them manually with handbrake to mp4. Then I converted them from mp4 to avi. Then I have finally got the movies working.
When I start the game the movies worked but the mouse and the whole game was laggy. I have fixed that with the fix mentioned above to start the game in 16bits color mode and it worked perfectly with movies on Windows 8.

To fix it you must do these stept.

1. update your game to 1.04
2. http : // www . multiupload . nl / H89XP2MQ7V - Movies download in avi.
3. start game in 16bit color mode and your done.
As long as we're posting links to converted videos, here's my version:
http : // www . mediafire . com / ?fb4j8sv8c7wl5w6

They're about the same size as the originals, and I'm pretty confident in the quality :)

Edit: Oops, the password for the archive is "SepterraGoG" (without the quotes).
Post edited November 01, 2013 by VerGreeneyes
Doesn't work.

If i do that and delete the old vids, then the game asks for the Game CD

If i Keep the old Video in the Folder, the game works, but without vids
I have Windows XP SP3 and I get a simple "Transcoding failed" message when using the installer. I imagine there are some codecs or something I need to install. When I run the game, I just get a black screen then eventually it dumps me back to the desktop.
Never mind - the fix mentioned in another thread (installing an old version of QT) worked just fine for me.

http://www.gog.com/forum/septerra_core_legacy_of_the_creator/fix_for_windows_8_problems_works_100
Im confused, the patch failed to transocde the videos and videos dont play ingame. What should i do? Im already running in XP compatability mode with quicktime 4 installed...
Post edited December 11, 2013 by Question