It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
The game worked fine before numerous times but when I went back to play today the game won't open and gives me the message I wrote in the title.

I'm using Vista Home Edition.

If there is a easy solution to this, please let me know. Thanks.
There's a couple of things you could try out.
1. Have you tried to run the executable inside the Sanitarium folder instead of the default GOG
wrapped one?
If not, try to run it, if it works make a new save and try to run the default GOG wrapped executable again.

2. Is the game installed outside the default "Program Files" folder?
If not, install the game outside this folder (e.g. C:\Games\...).
Post edited March 04, 2012 by senbon
Hi!

Same problem here. Tried everything and have now surrendered to Virtual PC 2007. Installed XP on it and guess what? The issue remains. So I'm pretty sure it's not a Windows 7 only issue. Any ideas what might cause / fix this?
Just to let you know: I've managed to play through Sanitarium. I found that saving often reduces the crash rate a lot! I've just played the last two chapters for about 2 hours and it didn't crash once.
If you save after every major accomplishment, you should be safe. And if not: at least you won't have to do a lot of stuff a second time ;)
Same here. It's not the end of the world to just save regularly and seems to become more stable with time... It's good general adventure-game practice to get used to in any case, a game can crash for any number of reasons.
avatar
SirDregan: Just to let you know: I've managed to play through Sanitarium. I found that saving often reduces the crash rate a lot! I've just played the last two chapters for about 2 hours and it didn't crash once.
If you save after every major accomplishment, you should be safe. And if not: at least you won't have to do a lot of stuff a second time ;)
avatar
burgercomics: The game worked fine before numerous times but when I went back to play today the game won't open and gives me the message I wrote in the title.

I'm using Vista Home Edition.

If there is a easy solution to this, please let me know. Thanks.
if that happens best thing to do is uninstall the game leaving the save game intact and reinstall the game it fixes it every time for me been having that problem with the hard copy of the game since it came out
avatar
burgercomics: The game worked fine before numerous times but when I went back to play today the game won't open and gives me the message I wrote in the title.

I'm using Vista Home Edition.

If there is a easy solution to this, please let me know. Thanks.
I'm replying to an old message I know, but I just installed Sanitarium, and I think I had the same error when trying to launch the game.

In my case, the fix was to go to Sanitarium shortcut properties => compatibility, and enabling "Run this program as an administrator". After that the game lauched and ran fine. I've now played somewhere to 2nd chapter without issues.

Specs: Lenovo ThinkPad T400 laptop, Windows 7 64bit.

So could it be that for some reason that compatibility flag was accidentally removed from your game, hence it didn't work anymore? Then again, in my case it wasn't there after installation, I had to go enable it.