It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
Anyone have Sacrifice working with Windows 7 RC?
I've tried a bunch of options including turning pretty much every advanced graphic feature off and a few different compatability settings at the Windows level with no luck...the 1st tutorial runs OK but you can't start the campaign. Sacrifice crashes after about 30 seconds.
I've got an Nvidia 8600GTS and have tried the latest WHQL and Beta nvidia drivers for WIn7.
This question / problem has been solved by zakameimage
It works for me after installing the patch 3. When I installed windows 7, Sacrifice would not come up and then I reinstalled sacrifice and I had the same problem. As soon as I installed the patch 3, it worked!!!
How do you install patch 3?
I downloaded it and it did not recognize the GOG sacrifice install.
It thinks I don't have the game.
avatar
eskowron: How do you install patch 3?
I downloaded it and it did not recognize the GOG sacrifice install.
It thinks I don't have the game.
Likely he has the disc version.
Post edited September 25, 2010 by chautemoc
As far as we can tell, it's a combination of Nvidia drivers and Windows 7 x64 that is the root of the problem. The discussion (and attempts to find a fix) continues in the Major Graphical Glitches thread.


-Khalaq
Post edited November 06, 2010 by Khalaq
A long time ago I bought this game here and was so sad to find nothing would work to fix the Windows 7/ Nvidia issues.
But I stumbled upon the Steam game forums just recently for Sacrifice and found the solution!!

Here it is, it works perfectly!! If only GOG knew about this sooner!

I've basically copied and pasted this from an older forum post - so don't worry if you have much more up to date drivers than mentioned:

Nvidia has released new drivers this month which includes a compatibility bit which you can use for the appropriate settings for Sacrifice, fixing this problem!

1) Install the most recent drivers (266.58) from the nVidia website. (They do not appear to currently be available through Windows update.)
2) Download the program Nvidia Inspector, which allows you to set up custom profiles per game (like Sacrifice). Nvidia Inpector is available from links here: http://majorgeeks.com/NVIDIA_Inspector_d6630.html
3) Extract the files in the download to a directory, and run the executable nvidiaInspector. This will open up a dialog giving various health information about your system.
4) In the middle right-ish of the dialog, to the right of where it list your driver version, is a button with a wrench icon. click it to set up a new profile (you may prompted to allow the program to make changes.)
5) Create a new profile by clicking the small orange 'star' icon on the taskbar at the top of the new window. Name it whatever you wish
6) In the section of buttons immediately to the right of the new profile button section, there is an "Add Programs to profile" button. Click it, and add your Sacrifice executable to the profile. (Mine, for example, is C:\Program Files (x86)\Steam\steamapps\common\sacrifice\sacrifice.e xe)
7) A few button sections to the right is button with an icon of a magnifying glass over some gears. Click this to discover extra options (this may take a moment).
8) Scroll down to the "Unknown" section of values. There will be a setting with the name PRE_D3D_COMPATIBILITY_BITS (0x0090F680). Either using the dropdown or typing it in manually, set the value to 0x00000040. (If selecting from the dropdown, there will be a list of game titles that should use this setting.)
9) Apply the settings, close the inspector, and use your Nvidia compatible copy of Sacrifice!

And there you have it! Hope this helps! :D
avatar
sk8fuze: (complex fix information)

And there you have it! Hope this helps! :D
This worked perfectly! Thanks so much for posting it!
Im having a hard time getting sacrifice runing smooth ive tried lowest settings at low res and still unplayable. ive updated all my drivers and im running a fairly new system any suggestions are appreciated
I did exactly what you wrote here (Latest drivers downloaded 305.93 and Inspector 1.9.6.6 installed. Made new profile, added sacrifice.exe in the profile and adjusted the setting by copy-pasting your hex-figure and hit apply. Then I ran the game normally) and it immediately seems better. However the game still freezes (audio and input (like ESC)) still work but nothing appears on the screen but the frozen image.

ALT/TAB out and back in and the screen is black but he sound still works and the esc key triggers the sound of the menu pop-up.

WIN7x64+Nvidia Quadro880M

Please, I really don't want any replies saying: "Quadro/M; Insert random negative phrase here".

avatar
sk8fuze: A long time ago I bought this game here and was so sad to find nothing would work to fix the Windows 7/ Nvidia issues. But I stumbled upon the Steam game forums just recently for Sacrifice and found the solution!! Here it is, it works perfectly!! If only GOG knew about this sooner! I've basically copied and pasted this from an older forum post - so don't worry if you have much more up to date drivers than mentioned: Nvidia has released new drivers this month which includes a compatibility bit which you can use for the appropriate settings for Sacrifice, fixing this problem! 1) Install the most recent drivers (266.58) from the nVidia website. (They do not appear to currently be available through Windows update.) 2) Download the program Nvidia Inspector, which allows you to set up custom profiles per game (like Sacrifice). Nvidia Inpector is available from links here: http://majorgeeks.com/NVIDIA_Inspector_d6630.html 3) Extract the files in the download to a directory, and run the executable nvidiaInspector. This will open up a dialog giving various health information about your system. 4) In the middle right-ish of the dialog, to the right of where it list your driver version, is a button with a wrench icon. click it to set up a new profile (you may prompted to allow the program to make changes.) 5) Create a new profile by clicking the small orange 'star' icon on the taskbar at the top of the new window. Name it whatever you wish 6) In the section of buttons immediately to the right of the new profile button section, there is an "Add Programs to profile" button. Click it, and add your Sacrifice executable to the profile. (Mine, for example, is C:\Program Files (x86)\Steam\steamapps\common\sacrifice\sacrifice.e xe) 7) A few button sections to the right is button with an icon of a magnifying glass over some gears. Click this to discover extra options (this may take a moment). 8) Scroll down to the "Unknown" section of values. There will be a setting with the name PRE_D3D_COMPATIBILITY_BITS (0x0090F680). Either using the dropdown or typing it in manually, set the value to 0x00000040. (If selecting from the dropdown, there will be a list of game titles that should use this setting.) 9) Apply the settings, close the inspector, and use your Nvidia compatible copy of Sacrifice! And there you have it! Hope this helps! :D
avatar
simone83: I did exactly what you wrote here (Latest drivers downloaded 305.93 and Inspector 1.9.6.6 installed. Made new profile, added sacrifice.exe in the profile and adjusted the setting by copy-pasting your hex-figure and hit apply. Then I ran the game normally) and it immediately seems better. However the game still freezes (audio and input (like ESC)) still work but nothing appears on the screen but the frozen image.

ALT/TAB out and back in and the screen is black but he sound still works and the esc key triggers the sound of the menu pop-up.

WIN7x64+Nvidia Quadro880M

Please, I really don't want any replies saying: "Quadro/M; Insert random negative phrase here".

avatar
sk8fuze: A long time ago I bought this game here and was so sad to find nothing would work to fix the Windows 7/ Nvidia issues. But I stumbled upon the Steam game forums just recently for Sacrifice and found the solution!! Here it is, it works perfectly!! If only GOG knew about this sooner! I've basically copied and pasted this from an older forum post - so don't worry if you have much more up to date drivers than mentioned: Nvidia has released new drivers this month which includes a compatibility bit which you can use for the appropriate settings for Sacrifice, fixing this problem! 1) Install the most recent drivers (266.58) from the nVidia website. (They do not appear to currently be available through Windows update.) 2) Download the program Nvidia Inspector, which allows you to set up custom profiles per game (like Sacrifice). Nvidia Inpector is available from links here: http://majorgeeks.com/NVIDIA_Inspector_d6630.html 3) Extract the files in the download to a directory, and run the executable nvidiaInspector. This will open up a dialog giving various health information about your system. 4) In the middle right-ish of the dialog, to the right of where it list your driver version, is a button with a wrench icon. click it to set up a new profile (you may prompted to allow the program to make changes.) 5) Create a new profile by clicking the small orange 'star' icon on the taskbar at the top of the new window. Name it whatever you wish 6) In the section of buttons immediately to the right of the new profile button section, there is an "Add Programs to profile" button. Click it, and add your Sacrifice executable to the profile. (Mine, for example, is C:\Program Files (x86)\Steam\steamapps\common\sacrifice\sacrifice.e xe) 7) A few button sections to the right is button with an icon of a magnifying glass over some gears. Click this to discover extra options (this may take a moment). 8) Scroll down to the "Unknown" section of values. There will be a setting with the name PRE_D3D_COMPATIBILITY_BITS (0x0090F680). Either using the dropdown or typing it in manually, set the value to 0x00000040. (If selecting from the dropdown, there will be a list of game titles that should use this setting.) 9) Apply the settings, close the inspector, and use your Nvidia compatible copy of Sacrifice! And there you have it! Hope this helps! :D
avatar
simone83:
I have the same issue, did anyone actually solve this? It's getting frustrating that I can't play a game I bought...
I'm going to sum up things I've read here and there, including this topic. I hope this will help! (now the game is running fine for me)

I'm using: Windows 7 64bit, Intel i7, GeForce GTX 660M.

If you play on a recent laptop, it's likely that you've got an nVidia Optimus system. So make sure that the game uses your nVidia GPU rather than Intel HD (which isn't as powerful, even for old games - at the time being. Still, it can save the day on some games, but not here). As gog.com has set Sacrifice to run in Admin mode, you have to open nVidia Control Panel / Manage 3D settings / Programme settings / select the game (or search for the executable) / the in "2." choose nVidia High Perf / Apply / and close.

Ok, so now for what I gathered here and there.

First, with nVidia cards, using nVidia Inspector as described above helps quite a lot (the PRE-D3D bit, which you should select in the dropdown list). But other solutions can be tested on top of this one (you can change the following parameters either in your game settings in nVidia control panel, or in the Inspector. I suspect it'll be useful with ATi vards to check those too, with ATi Tray Tools e.g.):

- enable/force VSync (it will smooth camera movements further). Inspector provides another option (in the same category) which precisely defines how VSync is to work.

- try Triple Buffering too (I'm not sure the in-game parameter works OK, so try with the panel/Inspector), it may help with the controls

- pre-rendered frame: this is an option often used when there are issues with lagging controls. However, seting it too high may also crash the game.


Note that the game has some long-standing issues. As far as I remember, on my old GeForce 2 GPU, it would crash if "bump terrain maps" was selected (and it's still the case on modern nVidia GPUs - selecting detailed maps instead is good enough anyway). Also, it has always displayed clipping errors in mid-distance (more so on ATi). And camera movement stutters a little bit when you explore.
Post edited November 01, 2012 by Darucas
avatar
sk8fuze: A long time ago I bought this game here and was so sad to find nothing would work to fix the Windows 7/ Nvidia issues.
But I stumbled upon the Steam game forums just recently for Sacrifice and found the solution!!

Here it is, it works perfectly!! If only GOG knew about this sooner!

I've basically copied and pasted this from an older forum post - so don't worry if you have much more up to date drivers than mentioned:

Nvidia has released new drivers this month which includes a compatibility bit which you can use for the appropriate settings for Sacrifice, fixing this problem!

1) Install the most recent drivers (266.58) from the nVidia website. (They do not appear to currently be available through Windows update.)
2) Download the program Nvidia Inspector, which allows you to set up custom profiles per game (like Sacrifice). Nvidia Inpector is available from links here: http://majorgeeks.com/NVIDIA_Inspector_d6630.html
3) Extract the files in the download to a directory, and run the executable nvidiaInspector. This will open up a dialog giving various health information about your system.
4) In the middle right-ish of the dialog, to the right of where it list your driver version, is a button with a wrench icon. click it to set up a new profile (you may prompted to allow the program to make changes.)
5) Create a new profile by clicking the small orange 'star' icon on the taskbar at the top of the new window. Name it whatever you wish
6) In the section of buttons immediately to the right of the new profile button section, there is an "Add Programs to profile" button. Click it, and add your Sacrifice executable to the profile. (Mine, for example, is C:\Program Files (x86)\Steam\steamapps\common\sacrifice\sacrifice.e xe)
7) A few button sections to the right is button with an icon of a magnifying glass over some gears. Click this to discover extra options (this may take a moment).
8) Scroll down to the "Unknown" section of values. There will be a setting with the name PRE_D3D_COMPATIBILITY_BITS (0x0090F680). Either using the dropdown or typing it in manually, set the value to 0x00000040. (If selecting from the dropdown, there will be a list of game titles that should use this setting.)
9) Apply the settings, close the inspector, and use your Nvidia compatible copy of Sacrifice!

And there you have it! Hope this helps! :D
Thanks for this solution! This made the game playable on my end.
working!
I solved this on Win 7 64 bit by running in Compatibility for XP Service Pack 3.

I also Disabled Visual Themes, Desktop Composition and Display scaling.

The one that appeared to crack it was eunning it in 640x480.

Once I was in the game i set the required resolution, exited the program, turned off all the compatibility options
and it worked.