It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Anyone have Sacrifice working with Windows 7 RC?
I've tried a bunch of options including turning pretty much every advanced graphic feature off and a few different compatability settings at the Windows level with no luck...the 1st tutorial runs OK but you can't start the campaign. Sacrifice crashes after about 30 seconds.
I've got an Nvidia 8600GTS and have tried the latest WHQL and Beta nvidia drivers for WIn7.
This question / problem has been solved by zakameimage
avatar
patja: Anyone have Sacrifice working with Windows 7 RC?
I've tried a bunch of options including turning pretty much every advanced graphic feature off and a few different compatability settings at the Windows level with no luck...the 1st tutorial runs OK but you can't start the campaign. Sacrifice crashes after about 30 seconds.
I've got an Nvidia 8600GTS and have tried the latest WHQL and Beta nvidia drivers for WIn7.

Try running on lowest detail mode, max scars at around 80-100 and triple buffering off. I have an 8600GT and it stutters a lot at default settings, but doing the above worked for me.
Thanks, that seems to be working. Hopefully we get better drivers. I'm also looking into booting vista from a VHD as an alternative.
virtual hard drives only have a rudimentary graphics driver. You won't get games working on a virtual pc.
avatar
anonymous: virtual hard drives only have a rudimentary graphics driver. You won't get games working on a virtual pc.

Unfortunately VirtualBox only supports DirectX 8 and 9 acceleration, and this game uses 7. It'd be interesting to try it under Wine in Linux (running in VirtualBox).
It works flawlessly on my Geforce 6600 machine, which is also running on Windows 7.
However, I have the same problem on my main computer which has an 8800GT.
Maybe Nvidia will fix it with a driver in the future.
On xp I had to disable multi-mon for this to work. On win7 on a GTX295 I'm having trouble launching the game.
Even though this post is tagged "SOLVED," the problem persists. I've tried all of the "fixes" mentioned in both this topic and the other one and have yet to get the game to work properly. The source of the problem really does seem to be the Nvidia drivers, and I have doubts that Nvidia is going to be addressing this particular oversight any time soon.
I'm using a quad-core Pentium and 9800 GTX+ on Windows 7 x64 with the 197.13 drivers. The only solution that works for me is to give up playing Sacrifice until somebody fixes it.
-Khalaq
Post edited April 07, 2010 by Khalaq
I also have the same problems with Win7 Ultimate x64 edition. But not even lowering the options all the way down cures it for me. It still stutters when there's more than a handful of units on the map at any one time, and crashes badly soon afterwards.
Same problems here. Couldn't show th game to a friend on Win7 :/
If you are using Nvidia Graphics Cards ---> Go into Nvidia Control Panel Settings and under "Manage 3D Settings", enable or turn on "Extension Limit". Hopefully this helps Thank you!!
Drop by the Sacrifice lobby sometime and make sure to visit www.sacrificeplanet.net
Cheers!
Several forums are stating that sacrifice will not run on the 64 bit version of windows 7 but it runs fine on 32 bit windows.
avatar
AZTECAS_SP: If you are using Nvidia Graphics Cards ---> Go into Nvidia Control Panel Settings and under "Manage 3D Settings", enable or turn on "Extension Limit". Hopefully this helps Thank you!!
Drop by the Sacrifice lobby sometime and make sure to visit www.sacrificeplanet.net
Cheers!

Unfortunately adjusting the settings in the Nvidia control panel doesn't work either. The only solution until Nvidia updates it's drivers is to run an emulation of Win XP, which I am hesitant to do.
avatar
rotcmanpc: Several forums are stating that sacrifice will not run on the 64 bit version of windows 7 but it runs fine on 32 bit windows.

actually I play it on win y 64 bit, no problems.
I use an ati card (4870) and maxed out the video settings.
looks like its purely an invidia problem then.