It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

I am having problems with FPS, which is very slow and makes the game quite unpleasant to play. Main menu and everything before the actual in-game content are running very smoothly. I'm guessing somewhat 15-20 FPS. I really need to know if this is normal, since Sacred 2, for example, runs very fine with very smooth FPS.
My specs:
OS: Windows Vista Home Premium SP1
GPU: GeForce GTX 260
CPU: Intel E8400 (Dual-core; 3,6GHz clock)
Mobo: ASUS Striker Extreme
Hard Drive: Seagate Barracuda x 2
Thanks in advance!
This question / problem has been solved by Darcalusimage
Also, thanks for all the help. I wish GOG or someone would patch or come up with a REAL fix before making money off of a broken ass game.
Cypherasdf: ...

Sorry to hear that there is not a solution for you. Found this post about turning off vsync that seemed to help, you might try that if you haven't already.
You know what, forget being frustrated. Sorry about the attitude, I'm just gonna do every thing I can to figure this out.
Here's the lowdown.
I have an AMD 4200+ X2 with Win 7 Ultimate
Nvidia 8800 GTS (Recent drivers)
-Windows 98 compatibility makes the cursor drop to very low FPS making it stutter.
-4X AA makes the frames go to about 25 or less
-I have tried combinations of other options such as, V-Sync, triple buffer etc
-I tried adding WAITRETRACE : 0 in Settings.cfg. This disables V-Sync in game
-I set game to one core in windows, I am unable to do this in the BIOS.
-Win Xp compatibility seems to do nothing.
-I have tried all sorts of combinations of the above fixes.
I feel like I'm so close to figuring out what it is, funny enough the win 98 compat worked instantly on my xp machine.
Cypherasdf: ...

It seems you have tried all the recommended fixes. The only thing I have not heard you mention is limiting the memory. (Before trying this I would try running the game with Compatibility mode unchecked (off) on the game shortcut) Some folks have cured graphics slowdown / problems on Win 7 64 systems by limiting the memory. You would only do this while running the game and should make note of your original setting prior to trying this. Usually setting it at 3072 does the trick with 2048 the next setting to try if 3072 does not help. Set your memory back to your original setting after playing. I don't care for this method as it takes time and is too easily forgotten that you have limited your memory but . . . it does work for some folks. (I believe a reboot is required each time you change this setting) See the attached image (image courtesy of Undesirable) for a step by step.
Not to rehash but just to show the steps I do for a Win 7 64 bit game install.
1 - Make a system restore point. Create a directory C:\Games if it does not exist. Turn UAC to None before installing (off in Vista)(turn back on after installing.)
(If there is a previous install of the game, backup saves from previous games if they exist. Do an uninstall of the game and delete any directories / files for the game from previous installs under [install location]\\[game name] if they exist.)
2 - Optional for me, disconnect from the internet. Disable or shutdown Antivirus and firewall, the firewall especially can block disk / registry writes. Remember to enable both after the install. I disable them based on previous interference with game installs, if none, I will leave them running.
(My first install of Divine Divinity would not run as my firewall was throwing up confirmation request dialogs behind the game screen and closed them with the game which meant I would never see them. Some firewalls are set to "Block Silently" as well. Eventually, I ALT-TAB'd out, saw the confirmation dialogs, "allowed" the game initialization request and it ran great from then on. Once allowed, most firewalls will not ask again. I still ALT-TAB out of a new install on the first run with the firewall enabled since it seems necessary for some games an not for others, depending on each games initialization process. Either way, if disk / registry writes are blocked, it will affect how the game runs.)
3 - Install in a directory outside of Program Files / Program Files (x64). I usually use C:\Games as my game directory and create it prior to an install if it does not already exist. Install by right clicking the setup.exe and click "Run as an administrator" from the resulting dialog. On the first dialog of the GOG installer, click the Options button on the lower left corner and point the install to the new game directory
4 - After the install, right click the game shortcut, click Properties, click the Compatibility tab and check "Run this program as an administrator". On the same tab uncheck "Run this program in compatibility mode for", it seems on Win 7 some games run better without any compatibility mode enabled at all. I always start out with none and work my way from newest OS to oldest till I find the mode that works best . . . if I use any mode at all.
This should give a good install which leaves tweaking the game options and config files and video card setting as the only steps remaining. Most don't require anything else other than possibly setting the affinity to a single core for some games.
I believe you have done all of the above and tried all the tweaks for the game including running the Config.exe, which is located in the game install directory, and checking/unchecking 32 Bit Color Depth and Filter Active check boxes. I also think you are close to figuring it out. It is probably something simple but difficult to find and specific to your particular system.
Having said all that, I only have one other option that I have used on one Win 7 laptop. Since you are running Ultimate, you can download the XP mode from MS for free. It is only available to Professional and Ultimate Win 7 users. (Other Win 7 version users can upgrade to Professional for $79 using the "Anytime Upgrade" feature in Win 7, you can also buy the Anytime Upgrade key from BestBuy, seems all versions of Win 7 are always installed and you only need the key to upgrade)
What it does is create a Virtual XP Professional install on your system. It places a XP icon on your desktop, clicking it opens an XP window which, when maximized, is XP. I suggest you look at the videos at the bottom of this page for a walkthrough of the XP mode. I installed a problem game in the XP mode on Win 7 and it worked perfectly. I cannot guarantee this will work for you but it is another option you have available.
It is simple to setup the XP mode, download three files (the first is nearly 500 MB) and install them in the correct order, put the game on a USB stick (XP does not see your Win 7 install). There is a small tool bar at the top of the XP screen which allows you to activate a USB device, do that after which you navigate to the install file using XP's Windows Explorer and install as usual. It is a fully working version of XP SP3 so you will need to update using Windows Update and add a firewall and AV if you are using it while there is an active internet connection. I use AVG free edition since it works well, installs easily and is free. The default XP firewall is probably ok since you are not doing your everyday surfing with the XP mode. I also install Firefox etc. You will need to keep all programs and XP updated since it is a working OS.
The game install will put an icon on your XP desktop which will run the game as usual. You may still need to tweak the game even in XP. Close the game as usual and click the Close / X on the center XP tool bar or XP window to close the XP mode (it says hibernate)
Hope this helps as I have no other suggestions . . . =)
Post edited May 28, 2010 by Stuff
A quick and easy fix to help framerates is to go open settings file with notepad and change NETLOG from 1 to 0. hat can sometimes help.
Anyone gets higher performance with a dual or more cores by disabling all cores except one to Sacred? I just tried this on my quad and it didn't help anything. This is on Win7 64-bit. I play at window mode because I like my native resolution which it keeps. Zoom level 1 and 2 I have about 60FPS all the time but if I zoom out to the 3rd level I go to around 30 to 45FPS, lower during combat.

The AA filter sucks as I recall and you had better force through ATI CCC or Nvidias Control panel. Considering this game is old and have some performance issues running VSync without triple buffering will probably hammer performance a lot so I would try without it but it seems to work fine with me forcing through D3DOverrider.