It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

When I attempt to create a LAN game, the message box will sit at "Server status: up and running" but the message will never disappear and the server lobby will never appear. I can join other peoples games, I just can't host one myself. Has this been run into before? I'm running on XP.
No posts in this topic were marked as the solution yet. If you can help, add your reply
macdude22: Well, not sure it will work for everyone, but on my dual core here is how i managed to host a game.
1 Start "Dedicated Gameserver" from the start menu->>Sacred Gold (as Ois suggested in post #4)
2 Choose a name, keep default port and choose "LAN"
3 You can change game type from the "Game Configuration" menu
4 Launch Sacred Gold
5 Choose Multiplayer
6 Select your character, click next
7 Now you should see the game name you choosed on the server, JOIN it
8 Other players should be able to join too
If i try to host a new game from within Sacred, Gameserver.exe doesn't seem to load properly. At least it doesn't show in Process Explorer. I didn't try messing with cores so far as this trick seems to work.
And i kept network latency to DSL/Cable/LAN so that useless NPCs are not removed and i can see children run away from my demoness :D
BobMorane: EDIT: I'm an idiot. Forgot about the ISDN setting. However I'm using a quad core Windows Vista 64 bit and my friend is using windows 7 dual core, and we tried these methods listed on Hamachi, but still no go. Speaking of Hamachi, I can't find any help on google for Sacred Gold...just Sacred 2.
Post edited May 18, 2010 by GordonFreeman21
Has anyone figured out the LAN multiplayer dilemma? I've gone the gameserver route, and can get a game going, and can even see it in Sacred, but neither of us can join the game. We are both running Vista Home 64, and sharing a digital router and cable internet. I can get the multiplayer game established by starting up the "gameserver" application in the Sacred program folder, and can see it in the game. But neither of us can join the game, from either computer. Any thoughts??
Many thanks!
What error message are you getting when you try to join? That knowledge would help in figuring out what's wrong.
The message says:
Code -20: Kernel: cannot allocate logdata message
I had the exact same message when I tried to play this over LAN. What eventually solved it for me was to have all of us who were trying to join the game go into the options menu and set "Data Flow" (the lower-rightmost options box) to "For MODEM\ISDN". The game would then let us enter. Hopefully, the same solution will work for you.
Let me know if it works! I certainly hope you can enjoy this game in multiplayer.
Post edited May 23, 2010 by Dsarvess
That worked!! Joe and I are eternally grateful. We had gotten tired of Titan Quest after the 3rd time through, so now we can start a new game. Many, many thanks again!
Glad to have helped!
That data flow option was the perfect solution for lan. thank you so much