It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like: Chrome, Firefox, Internet Explorer or Opera

×
I just installed two GOG.com games, FarCry and Sacred: Gold Edition. I had no problems with FarCry, but when I tried to run Sacred Gold, the screen goes blank with the Vista "working" icon, then drops to desktop giving me the error "Sacred Has Stopped Working."
I am running Vista (64 bit) and have rebooted. My system specs are as follows:
Intel i7 Core Extreme 3.2 Ghz Quad Core Processor
ASUS Rampage II Extreme Motherboard
12 GB of Corsair Dominator DDR 3 RAM
2 Western Digital 300 GB Velociraptor Hard Disks operating @ 10K RPM (One for Windows XP SP3, One for Windows Vista SP1)
2 Seagate 1.5 TB Hard Disks operating @ 7200 RPM
Sony 20x DVD-R/RW Drive
LG H20L Blu-Ray+R, HD DVD-R, DVD-R, CD-R 6x 2x 6x Drive
FSP Booster 5X Power Booster
Silverstone 1200W Modular Power Supply Unit
Creative Sound Blaster Titanium Fatality Pro Series Sound Card
2x eVGA nVidia GeForce GTX 295 each @ 1792 MB of Video RAM
Lian Li Armorsuit PC80 Black Aluminum Chasis
Cooler Master V10 Heatsink/CPU Cooling Unit
Logitech G9 Laser Mouse
Merc Stealth LED Backlighted Gaming Keyboard
nVidia 3D Vision bundle (3D Goggles and 120 Hz 22" Samsung Monitor)
I disabled and enabled UAC, I have run the program in administrator mode, and I have updated all of my drivers to their latest releases, as well as all Windows updates. I'm getting quite frustrated, as it seems others are able to run the game without issue, so I don't know if it is something I have somehow managed to over look. Any help would be greatly appreciated. Thank you.
Jeremy R. Mahon
gaer@pacbell.net
This question / problem has been solved by Ralackkimage
Go to the games directory and right click on every .exe file in the main directory. Tick "Run this program in compatibility mode for Windows XP SP2, Disable Visual Themes, Disable Desktop Composition & Run This Program as Administrator". Then make sure you are running from the underworld expansion exe rather then the orginal, it has the orginal campaign and everything but is meant to work better with vista 64bit.
If this doesnt work you could always install it on your Windows xp version assuming thats 32bit.
Just want to add, thats a sick computer must off set you back a fair bit.
Lol, after pulling my hair out for a couple hours, and getting artifacts and general slow-down (after I finally got in,) I simply saved myself the headache, and installed it on my WinXP drive, and now it runs flawlessly. Thanks for the help!
BTW: The system was only about $6500 US, which was probably a little high, but I didn't really bargain shop, either. Still, not an issue with it yet (aside from running a little hot, but I'm looking into a 5.25" bay fan that I can place adjacent to my Video Cards.) Getting fairly good FPS in Crysis, but I think I have to tweak and clean up my cabling inside. I was impressed that not a single part was defective, I think I got really lucky.
avatar
Ralackk: Go to the games directory and right click on every .exe file in the main directory. Tick "Run this program in compatibility mode for Windows XP SP2, Disable Visual Themes, Disable Desktop Composition & Run This Program as Administrator". Then make sure you are running from the underworld expansion exe rather then the orginal, it has the orginal campaign and everything but is meant to work better with vista 64bit.
If this doesnt work you could always install it on your Windows xp version assuming thats 32bit.
Just want to add, thats a sick computer must off set you back a fair bit.
Hey,

I just en counter a similar issue running Sacred on Windows 8. The program crashed on the loading screen. I realised it crash happened during the loading of Fonts.

I managed to fix this going into the font subfolder in the game directory, select all files, right click and select "Install".

Runs with no probs now :)
I'm running this game on windows 7.

Well I am TRYING to run the game.

It won't start. I get a black screen, then 'sacred has stopped working'.

I can't play this game that I just paid for :( This sucks.
For me it works fine on WIndows 7 64 Bit (Professional), even without compatibility mode and without admin rights.

It is just annoying that Aero is always deactivated on game start up, especially because it would run with activated Aero on my machine, too. I managed to run it in Aero a few times after quickly closing and restarting it.

All in all, I did nothing special to make it work, it just worked out of the box. I even dont expire any slow downs and such stuff. Maybe it is the combination of Hardware, Software, Drivers or Configuration (especially in your graphics driver) on your system, that cause this problems.
Post edited November 07, 2013 by ThomasD313
I'm having problems with this now too, running it on my Windows 8 laptop from HP with QuadCore processor.

It's right there in the loading screen, only goes a LITTLE way before it stops there, saying it's because of "Type Manager" or something like that. How do I fix this?
Just want to say that I have just installed Sacred Gold and was experiencing freezing problems with it. It turned out that it doesn't like SLI (nVidia drivers). Switch it to use single GPU in the nVidia control panel and it runs without freezing... for me.