It seems that you're using an outdated browser. Some things may not work as they should (or don't work at all).
We suggest you upgrade newer and better browser like:Chrome,Firefox,Internet Explorer orOpera

×
Solution:

WINE
Wineskin version 2.5.8
Engine WS8Wine1.2.3

RESONANCE SETUP

√ Run in a window instead of fullscreen
Graphics driver: Direct Draw 5
Post edited May 06, 2013 by Torjus
No posts in this topic were marked as the solution yet. If you can help, add your reply
avatar
Torjus: The facts:

Downloaded resonance installer via latest GOG Downloader on 26 APR 2013.

WINE
Wineskin version 2.5.8
Engine WS8Wine1.2.3

RESONANCE SETUP

√ Run in a window instead of fullscreen
Graphics driver: Direct3D 9
Graphics filter: 2x nearest-neighbour filter

Digital Sound: Default DirectSound Device
MIDI Music: Default MCI Music Device
√ Use speech pack if available

√ Side borders on widescreen monitors

- - -

'Save and Run' button leads to a white X11 screen titled Resonance and a program error box which does display correctly.

Should I force Wineskin to run in Quartz? What else can I do to get Resonance running?

Please note: I cannot run Windows or Linux.
Have you tried running our version of Resonance that we set up to run on Mac OS X? Because from what I gather from your post, it sounds like you're running the Windows installer instead. Correct me if I am wrong :D
avatar
JudasIscariot: Have you tried running our version of Resonance that we set up to run on Mac OS X? Because from what I gather from your post, it sounds like you're running the Windows installer instead. Correct me if I am wrong :D
Correction provided. I am talking about the Mac OS X version from the resonance_1.0.0.2.dmg file.

After mounting the disk image, I moved the Resonance application to my Applications folder, double-clicked to run it, and received the white-screen problem described above.

I then redownloaded with the GOG Downloader and encountered the same problem.

So, then I right-clicked the Resonance App -> Show Package Contents -> opened Wineskin -> Advanced to find out which version came installed with the Mac OS X GoG App, and reported those values.
Post edited April 28, 2013 by Torjus
avatar
JudasIscariot: Have you tried running our version of Resonance that we set up to run on Mac OS X? Because from what I gather from your post, it sounds like you're running the Windows installer instead. Correct me if I am wrong :D
avatar
Torjus: Correction provided. I am talking about the Mac OS X version from the resonance_1.0.0.2.dmg file.

After mounting the disk image, I moved the Resonance application to my Applications folder, double-clicked to run it, and received the white-screen problem described above.

I then redownloaded with the GOG Downloader and encountered the same problem.

So, then I right-clicked the Resonance App -> Show Package Contents -> opened Wineskin -> Advanced to find out which version came installed with the Mac OS X GoG App, and reported those values.
Ahh ok thanks. Looks like I need to brush up on my Mac OS X knowledge, then :P

Please write to our Support department and send in all the necessary info i.e. hardware and os version etc. Thanks and sorry for the confusion :D.
avatar
JudasIscariot: Ahh ok thanks. Looks like I need to brush up on my Mac OS X knowledge, then :P

Please write to our Support department and send in all the necessary info i.e. hardware and os version etc. Thanks and sorry for the confusion :D.
Will do. I'll update the post once I get the App running.
avatar
JudasIscariot: Ahh ok thanks. Looks like I need to brush up on my Mac OS X knowledge, then :P

Please write to our Support department and send in all the necessary info i.e. hardware and os version etc. Thanks and sorry for the confusion :D.
avatar
Torjus: Will do. I'll update the post once I get the App running.
I have the sam problem, but on Mid-2012 MacBook Pro Retina with OS X 10.8.4 installed. I can’t get the game to work on ANY of the settings included in the launcher.

Any chance of us, Mac users, to receive latest patches, like Windows users as well?
avatar
shadowfacex: I have the sam problem, but on Mid-2012 MacBook Pro Retina with OS X 10.8.4 installed. I can’t get the game to work on ANY of the settings included in the launcher.
Did you read Judas's second paragraph? Try that.
Post edited July 10, 2013 by Gydion